Welcome to Premiere Pro 15.2!

Adobe Employee ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Update Icon.pngPremiere Pro 15.2 (May 2021 release) is now available for download from the Creative Cloud desktop app. This update includes numerous bug fixes, several new features, and performance improvements.

  • This update is recommended for all users. 
  • If you are experiencing any issues, please create a new post explaining your issue so we can help.
  • If you have a bug to report or any complaint please do that on User Voice, not here.

 

New Features in Premiere Pro 15.2

 

texrgradient.png.img.png

Text gradients
You can now add visual impact to titles and text with new tools in the Essential Graphics panel for adding gradients.. More info about text gradients here.

 

labelcolor.png.img.png

Label colors for captions

Caption items in the Captions track now have the same label color options as other items on the timeline.

Info about this feature is here.


trimcaption.png.img.png

Improved caption trimming

Edit video files containing embedded captions more intuitively. Caption items are linked to their associated video and audio clips, making it easier to fine-tune edits and keep everything in sync on the Timeline. More info here.

 

loudness.png.img.png

New Loudness Meter
The new Loudness Meter transparently measures program loudness for full mixes, single tracks, or buses and submixes. More info here.

displayimprovement.png.img.png

Support for DirectX12 display technology on Windows
DirectX now replaces OpenGL as the default display rendering technology for Premiere Pro, providing improved stability. DirectX also supports native High Dynamic Range (HDR) playback for Premiere Pro with HDR10-capable monitors and a DirectX-compatible GPU. More info here.

 

performanceimprovement.png.img.png
Canon XF HEVC performance improvements
Performance optimizations in Premiere Pro mean smoother playback and scrubbing on the timeline, as well as faster seeking. More info here.

New Features

User Guide

Fixed Issues

Known issues

TOPICS
FAQ, How to

Views

7.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

Can't wait to get a hold of this, optimized my schedule for this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Both audio and video on my timeline doesn't snap together anymore since this update. I have the magnet icon on while trying this and it still wont snap like it use to. Mac OS Mojave Version 10.14.6 as well as Windows10 OS version 21H1. Premiere on both computers up to date as of June 1, 2021. Screencap is from Mac. It can line up on a whim, but is very hard to do.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Eli,

This is more of an announcement post, so no one is likely to help you.
Shall I move it to the main forum?

 

Thanks,

Kevin

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

LATEST

Since I'm using versions 15.2 on my laptop I see a shift in color when I toggle between my proxies on or off. When I use version 15.1 I don't have that problem. The result is a washed out export. I tried this with several of my projects and all of them show the same behaviour. The footage is all shot with the Canon R5, HEVC 10 bit 4:2:2.

My system:

Intel (R) i7-8550U CPU, 1,80 GHz, 1992 MHz, 4 core('s), 8 logical processors
Intel (R) UHD Grahpics 620 GPU
Memory (RAM): 20 GB

I added some attachments

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines