Why am I getting these artifacts in a screen replacement?

Participant ,
Jan 17, 2021

Copy link to clipboard

Copied

I’m doing a screen replacement in a static shot by simply superimposing (on a higher layer) a JPEG of the screen I want over the screen in the shot. In the attached screencap, the upper photo shows what I see while positioning the JPEG. The lower photo shows what’s displayed during playback. The problem is those black artifacts across the white lines, kind of moireish. What’s more, I’ll get the artifacts if I scrub through the clip a frame at a time, but they’ll disappear if I stop on a frame for more than a couple of seconds. The Program Monitor resolution is set to Full.  Any ideas about what’s causing them and how to eliminate them greatly appreciated.

TOPICS
Editing, How to

Views

122

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Contributor , Jan 17, 2021
FlyingFourFun Contributor , Jan 17, 2021
Am_I_lame? there is one other setting in preferances called "high quality playback" that would likly correct the visual issue you are seeing.  However, it comes at a high cost to playback performance and is generaly never turned on.  You may want to enable it for certain projects and then turn it off.  As mgrenadier points out rendering that timeline should clear that up on your playback.  The truth of the matter is that what your seeing is normal when certian conditions occur, such as a really ...

Likes

Translate

Translate
Jump to answer Jump to answer
Advocate ,
Jan 17, 2021

Copy link to clipboard

Copied

I can't see your screenshot cause it's a link and I don't click on links generally speaking.

There's a way to post screenshots and images ( jpg's ) so nobody has to click on links.

Sounds weird... what you described happening... what's the size of the jpg and are you using proxy for video ?

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Participant ,
Jan 17, 2021

Copy link to clipboard

Copied

Ah, sorry about that, salvo34.  Here's the screencap embedded.  The JPEG is 900KB, 1272 x 1908, scaled down to 9% within PP.  I'm not using proxy for video.  Based on mgrenadier's comment I exported the clip and the artifacts are gone, so I'm less concerned, but I'd still like to eliminate them within PP.

Screen replacement.jpg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 17, 2021

Copy link to clipboard

Copied

great username.  have you tried rendering the timeline?  you can mark an in and out and just render part of it.  You might also try exporting and see what it looks like.  Premiere has a bunch of controls for how the program monitor is displayed and they are not always intuitive but once you get a handle on them, they do kind of make sense.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 17, 2021

Copy link to clipboard

Copied

Am_I_lame? there is one other setting in preferances called "high quality playback" that would likly correct the visual issue you are seeing.  However, it comes at a high cost to playback performance and is generaly never turned on.  You may want to enable it for certain projects and then turn it off. 

 

As mgrenadier points out rendering that timeline should clear that up on your playback.  The truth of the matter is that what your seeing is normal when certian conditions occur, such as a really thin line either vertical or horizontal that happens to align with where the downres routine decides to remove pixles from.  The high quality playback in preferances may get you a better result for this one condition, but it really can hurt overall performance of playback so its not a good idea to turn it on.  (I would however suggest you try it if you have not done so before and see what you think of it, and to know how it works in case you ever need to use it).

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Participant ,
Jan 18, 2021

Copy link to clipboard

Copied

> "high quality playback"

 

Bingo!  That fixed the problem, FlyingFourFun.  Thanks.  I couldn't find it under Preferences, though; it was on the context menu on the Program Monitor.  So far it doesn't seem to hinder anything on my machine (3.6 GHz Xeon, 64GB RAM, GTX1080), but I haven't added any effects or transitions yet.  Easy enough to turn off if it becomes a problem.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Jan 18, 2021

Copy link to clipboard

Copied

Glad this helped you out...  I think you will find that as you layer effects and more complex ones, this setting will show its impact at some point - however now that timelines are played back with GPU it may not be as much of a drag on the system as it once was in the past (I just relized I have not retested this setting since GPU acceleration for playback changes for NVENC were added - which is what your benifiting from in your setup with the GTX1080)...  there is no hard and fast rule when that setting will be noticed, but your awarness of it will guide you if you need to turn it back off. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more