Why won't my cursor snap to edit points in Adobe Premier Pro CC 2017?

New Here ,
Jan 07, 2017 Jan 07, 2017

Copy link to clipboard

Copied

On premier, your cursor (when near it) automatically snaps to an edit point to make accurate cutting and setting easier. Moving two clips together was easy because they would automatically slide together. However, for some reason, this feature got toggled off and it's making editing very difficult. Does anyone know what feature it is and how to turn it back on?

[Moved from non-technical Forum Lounge to specific Program forum... Mod]

[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

Views

4.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 07, 2017 Jan 07, 2017

Copy link to clipboard

Copied

"S" is the snap shortcut or use the snap icon on the timeline - top left.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 09, 2017 Mar 09, 2017

Copy link to clipboard

Copied

Hi LifeOfRiley,

Have you tried the step suggested by shooternz? Please let us know the status.

Thanks,

Vidya

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2017 Mar 10, 2017

Copy link to clipboard

Copied

On premier, your cursor (when near it) automatically snaps to an edit point to make accurate cutting and setting easier.

This is a setting that you can turn on or of in the Preferences.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 10, 2017 Mar 10, 2017

Copy link to clipboard

Copied

Preferences > General > Snap playhead in timeline when Snap is enabled.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 06, 2021 Jul 06, 2021

Copy link to clipboard

Copied

LATEST

I have that enabled in timeline settings as we;; as have in abled in the sequence. I also can press the magnet to enable or diabled it. Yet it still does not work I am currently on PRemiere pro 15.2.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2017 Mar 10, 2017

Copy link to clipboard

Copied

As mentioned by Ann, you can set this permanently in preferences. But chances are you mostly want it off, and sometimes want it on... This is when holding the SHIFT key comes in handy:

Hold down the SHIFT-key when you want the Video Cursor to snap in the timeline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines