Highlighted

Only Using integrated graphics

New Here ,
Oct 17, 2018

Copy link to clipboard

Copied

By default rush is using the intel graphics. I have a fully functional GTX 1080 that is NOT being used at ALL. How do I configure this?

Hi josephj22824825 ,

Welcome to the Rush community.

I don't think you can do that from the Rush interface but you might be able to do that from the NVIDIA Control Panel.

  1. Open the NVIDIA Control Panel
  2. Go to Manage 3D Settings > Program Settings
  3. Click Add to add Premiere Rush CC in the list of applications
  4. After Rush has been added to the list, select the preferred graphics processor as High-performance NVIDIA processor
  5. ​Click ​Apply

Screenshot_9.png

Hope this helps.

Rameez

Views

3.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Only Using integrated graphics

New Here ,
Oct 17, 2018

Copy link to clipboard

Copied

By default rush is using the intel graphics. I have a fully functional GTX 1080 that is NOT being used at ALL. How do I configure this?

Hi josephj22824825 ,

Welcome to the Rush community.

I don't think you can do that from the Rush interface but you might be able to do that from the NVIDIA Control Panel.

  1. Open the NVIDIA Control Panel
  2. Go to Manage 3D Settings > Program Settings
  3. Click Add to add Premiere Rush CC in the list of applications
  4. After Rush has been added to the list, select the preferred graphics processor as High-performance NVIDIA processor
  5. ​Click ​Apply

Screenshot_9.png

Hope this helps.

Rameez

Views

3.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 17, 2018 1
Adobe Employee ,
Oct 18, 2018

Copy link to clipboard

Copied

Hi josephj22824825 ,

Welcome to the Rush community.

I don't think you can do that from the Rush interface but you might be able to do that from the NVIDIA Control Panel.

  1. Open the NVIDIA Control Panel
  2. Go to Manage 3D Settings > Program Settings
  3. Click Add to add Premiere Rush CC in the list of applications
  4. After Rush has been added to the list, select the preferred graphics processor as High-performance NVIDIA processor
  5. ​Click ​Apply

Screenshot_9.png

Hope this helps.

Rameez

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 18, 2018 2
Adobe Employee ,
Nov 05, 2018

Copy link to clipboard

Copied

Hey there, josephj22824825!

Have the graphics been working for you? Let us know if there's anything else we can do for you!

Caroline

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2018 1
New Here ,
Mar 23, 2019

Copy link to clipboard

Copied

I have the same issue since Adobe Premiere Rush CC has been released.

I have two graphics cards:

Intel HD Graphics 630 - Driver version: 25.20.100.6566 DCH

NVIDIA GeForce GTX 1080 Ti - Driver version: 25.21.14.1967 (NVIDIA 419.67) DCH (NVIDIA Creator Ready Driver)

and

Windows 10 Version 1809 (OS Build 17763.379)

When I start Adobe Premiere Rush, Task Manager shows it is using GPU1 (NVidia), but as soon as I open a project, all processing occurs on GPU0 (Intel).

You can see on this screenshot when I started Adobe Premiere Rush CC:

2019-03-24_13-17-49.png

As soon I as close Adobe Premiere Rush CC, GPU 0 Utilization will go back to 0.

I don't have that setting in NVIDIA Control Panel, but I did manually select High Performance card for Adobe Premiere Rush CC in Windows settings:

2019-03-24_13-20-27.png

Still, when I open the project in Premiere, it switches from NVIDIA to Intel GPU.

I happened also with previous NVIDIA Drivers so I thought now, that I installed Creator Ready drivers that Adobe Premiere Rush CC will also take advantage of GPU but it does not.

Anything else for me to try?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 23, 2019 1
New Here ,
Mar 25, 2019

Copy link to clipboard

Copied

I am also having this same issue.

Set the app to use the nvidia discrete GPU but it still isn't fully using it.

I am exporting a video right now and it is using 100% of the integrated GPU.

Capture.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 25, 2019 1