Why Can't I Install on LG Stylo 4?

New Here ,
Jun 17, 2020 Jun 17, 2020

Copy link to clipboard

Copied

It just says "Your device isn't compatible with this version."  Same with PhotoShop Camera.  I would like to actually pay for and use these products.  What is the problem?

TOPICS
Mobile version

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

LATEST

The program is not yet compatible with your device.

https://helpx.adobe.com/premiere-rush/system-requirements.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines