Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Asian languages in TOC and Index of CHM appears as "?"

Explorer ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

Hi,

I'm using Robohelp 2020, I have a project in Japanese and Chinese. I have created TOC and Index, before generating the output the texts in TOC and Index looks fine and after generating Microsoft HTML help, The texts

on the TOC and Index navigation pane of the CHM file is appeared as "?".

I have tried changing the language in project settings and generated the output again, still the issue is persisting.

 

Could you please help me resolving this issue?

 

Thanks and regards,

Saravanan M

TOPICS
New UI

Views

333

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

I think this has been covered many times in the past and I believe the issue is they only work on machines where the language of the operating system matches. In other words, send the CHM to someone who has Chinese OS and it should work.

 

As I type this I can see a link in Related Conversations on the right pointing to such a topic. It's an old version of RoboHelp but some things never change.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

Thank you Peter Grainge for the detailed explanation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Hi Peter grainge,

 

The issue is with the below languages,

Chinese, Japanese, Korean, and Russia.

 

As you said, I have tried generating the HTML Help output from the Korean OS but still the issue is persisting. Also i gave a try changing the project settings language to korea and generated the output still facing the issue.

Saravanan4594_1-1619763077916.png

 

Note: This project is decompiled from the chm file using reverse engineering method posted in your site and upgraded from .xpj to .rhpj.

Is there any other way to solve this ?

 

Regards,

Saravanan M

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

This site gives lots of information about non-European chms. Check you've tried all the things recommended.

 

http://kb.helpwaregroup.com/ms-html-help/hh-tips-tricks/jp

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

I should not that there are a bunch of instructions specific to the tool that site sells, but most of the settings should be available in Robohelp. Theoretically you should solve the issue with just the Windows changes (it has for other people who've had this issue.

 

However, if those don't work, and you can't find where a specific setting is in RH, post with the specific step you're up to and need help locating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 30, 2021 Apr 30, 2021

Copy link to clipboard

Copied

Thank you So much amber, this helped me a lot.

The main Mistake i had done from the korean OS Machine is before generating i had only changed the project settings language not the default language setting in output preset > Microsoft HTML Help > General > Language.

After keeping the required language in both Project Settings and Output preset > Microsoft HTML Help > General > Language and generated the CHM. Now the inside content and also the TOC and Index in the Naviation pane appears as required.

🙂

Thanks and Regards,

Saravanan M

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Hi,

Everything was going good but recently I have figured out the search result is not working. Displaying pop up message "No topics found". 

Could anyone help me out from this issue?

 

Thanks in Advance.

Regards,

Saravanan M

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

You have changed your computer to the target language and rebooted before generating? That's the only information I can find for search not working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

Hi Amber, Thanks for the reply.

 

Yes, I have generated the korean output from the Korean Operating system. Still the issue persists.

 

Regards,

Saravanan M

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I think you'll need to contact support then. See the following page for support contact options:
https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Hi Amber,

 

There is an update! I could generate the Required Korean output with an English machine after the Korean language pack was installed, changing the language settings, rebooted the machine, and generated the output. Now the search is working fine.
But the content is fine only in the Korean OS Machine and the machine where the Korean language pack is installed.
If we copy the same file into the other machine the content looks like garbage characters. Could you help me to resolve this issue?

Saravanan4594_0-1620719416314.png

Regards,

Saravanan M

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I think any machine you want to use the chm on will have to have a Korean font installed. 

 

But I'm at the limit of what I can google for you as I haven't used CHM files in 20 years, and never non-English ones. So support is likely to be your best option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

LATEST

Thank you Amber for your Kind Response. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation