• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't get Filter Button to appear (RH 2022.1)

Participant ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

I created a simple RH project from scratch and added just a few topics. I then created some tags and tagged some content with each tag. I then created some Dynamic Content Filters that use the tags. I am using a Frameless template (RH 2022.1.188) based on Studio. When I generate my output, I don't see the Filter button. I verified that Laout > Topic Page Buttons (under the Studio template) had "Filter" as one of the buttons in the list. Is there something else I need to do?

 

Jim

 

 

Views

406

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 16, 2023 Mar 16, 2023

Did you select the dynamic content filter in the output preset?

Did you click down into a topic from the home page as it only displays on topic pages, not the home page?

Can you generate using a fresh copy of the Studio template to see if the button appears correctly without any customisations to the template?

Votes

Translate

Translate
Community Expert ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Did you select the dynamic content filter in the output preset?

Did you click down into a topic from the home page as it only displays on topic pages, not the home page?

Can you generate using a fresh copy of the Studio template to see if the button appears correctly without any customisations to the template?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

I've actually been having this same issue.

I made sure the Dynamic content filter was selected, I used a fresh copy of the Studio template, but the Filter button does not appear in the Home Page nor in the Topic pages. This is only apparent after I generate the Frameless output, as when I am in Robohelp checking the template, the button is there.
Do you have any idea what could be the issue here?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

@Filipe27301169zkrw if you try using a different form of output as a test, does it appear then?

[Edit - you might also try updating to Patch 2 to see if that makes any difference]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

@Jeff_Coatsworth , I have tried HTML5 output, and the issue remains: the Filter button is nowehere to be found.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

Thank you @Amebr . When I added a filter to the output presest (as you suggested), the button appears. But what if I only want to use filters for filtering out text withing a page? In other words, I want all of my topics to be in the output. I guess I make a filter that contains all my tags and use that in the output preset?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 16, 2023 Mar 16, 2023

Copy link to clipboard

Copied

The dynamic content filters don't exclude any content from the output. You have to select the filter in the output preset so that the options you want your users to be able to filter on will display.

 

Condition Expressions exclude content from the output.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

@Amebr: You are right. I was getting the two mixed up. Thanks again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

@Filipe27301169zkrw Are you saying this icon does not appear in the generated output?

 

image.png

 

BTW Update 2 is available but as you are on 2022.1 you cannot update from the Help menu. Follow this link https://helpx.adobe.com/robohelp/using/whats-new-robohelp-2022-release-update-2.html and click the link in the red box.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2023 Jun 02, 2023

Copy link to clipboard

Copied

Hey @Peter Grainge , thank you for your reccomendation. I will try to update my version to see if it solves the issue.

As of now, the Filter button that you pointed out is precisely the one that is missing when I generate the output, despite being present when I edit the template/skin within Robohelp.

I will let you know if the update fixes the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 02, 2023 Jun 02, 2023

Copy link to clipboard

Copied

OK but I didn't suggest Update 2 as a solution to your problem, I was just alerting you to the fact you are not on the latest version.

 

Post back when you have tried Update 2.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2023 Jun 07, 2023

Copy link to clipboard

Copied

Thank you, Peter. Indeed it seems the update did not solve the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 04, 2023 Jun 04, 2023

Copy link to clipboard

Copied

Perhaps a screenshot of your dynamic content filter setup and the relevent screen in the output preset where you selected it would help with troubleshooting?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2023 Jun 07, 2023

Copy link to clipboard

Copied

So I have now noticed that I've been having with the Filter button is happening with the Footer of the template as well: it appears in Robohelp,
Sample_Output_Template 1_edited.pngSample_Output_Template 2_edited.png


but not in the generated output:

Sample_Generated_Output_1_edited.pngSample_Generated_Output_2_edited.png


I tried to create a project from scratch, including the template skin, output preset and dynamic content filter, but anytime a generate the output, the same occurs. So I'm at a lost to what I'm missing.
Sample_Output_Content filter_edited.pngSample_Output_Preset_edited.pngSample_Output_Template 1_edited.pngSample_Output_Template 2_edited.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 07, 2023 Jun 07, 2023

Copy link to clipboard

Copied

@Filipe27301169zkrw See the Contact page on my site and send the new project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2023 Jun 19, 2023

Copy link to clipboard

Copied

Thank you, @Peter Grainge ! I really appreciate your availability. I have just sent you both an e-mail and a Wetrasnfer link for you to check the issue. It includes a new project I have created, as well as an Output that shows the missing Filter button and section, and the missing Footer,

Please let me know if you need anything else.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

In the project you sent me there was only one topic so filtering would never work. I added another topic and then applied tags as shown.

 

image.png

 

Filtering then worked after I removed the Condition Expression from the preset. You had an expression that excluded the topics.

 

Have you applied build tags in your main project?

 

I'll look at the footer issue later.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

Hello, Peter.

Indeed, on my main project I tried both with and without the condition expression. And yes, I have condition tags set up on my main project.

In any case, I also tried recreating what you described in your comment, and I had the same issue: No Filter button or Footer on the generated output.

May I ask, were you able to see any of this when you generated it on your end?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

I wouldn't have posted that if it didn't work!

 

image.png

 

All I did in the project you sent was apply tags to two topics and remove the content expression as in this project it caused a conflict. When you added the second topic, did you also add it to the TOC?

 

Have you added a second topic and applied tags.

 

On the footer I said I would look at that later and I will post back when I have an answer. At the moment I am in dialog with Adobe as there does seem to be an issue.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

I have sent you the working project.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

I have resolved the footer issue with Adobe's help but I have to go out right now. Will post later today.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

Thank you so much for the help, Peter. I was able to finally see the condition tags. I then recreated the steps you described to try and understand the original issue. I was originally trying to use the dynamic expression on a TOC that was composed by two other subordinate TOCs. As I wanted the dynamic expression to apply to the subordinate TOCs, I did not think that I had to also add tags to the original TOC. As soon as I did, the Filter button finally showed up.

 

I look forward to hearing how you were able to resolve the Footer issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 20, 2023 Jun 20, 2023

Copy link to clipboard

Copied

Steps for creating a static footer.

 

Create a topic with the content you want. For example, a three cell footer in which you create your content or links. This can be with or without a border, a table makes it easier to position the content.

 

In the template editor go to Layout > Home Page and select Static Footer, then go to Topic Page and select the same setting.

 

image.png

 

In the preset, browse to the topic you created.

 

image.png

 

Generate the output.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2023 Jun 23, 2023

Copy link to clipboard

Copied

LATEST

Thank you once again, Peter. It's a shame that the original footer of the template doe snot appear, as it was very handy. However, the solution you explained works just fine. The only thing I did not apply was the static filter, as I prefer to only have the footer at the bottom of the page.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp