Conditional tagging not working

Explorer ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

Hi there,

I'm working on Robohelp 2020, I have added conditional tagging for two of my contents and used Frameless and PDF outputs to execute, but the output looked different. I have applied conditional tags for a para and 2  points of bulleted lists but the content in the bulleted lists were removed and the bulleted lists icon appear in the output. I have attached the screenshots, please help me to fix this issue.

TOPICS
Output presets , Version control

Views

76

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 23, 2022 Mar 23, 2022
The solution will be the same, just with a slightly different tag. I can't tell you what to pick though because I don't know what your code is like. Probably you need to pick the p tag, but as I said, it depends on the code behind the scenes. A screenshot of the source that includes the tag breadcrumbs can help us help you, if you can't figure out the correct tag yourself. Also, please use the Insert Photos icon to include your screenshots, as that will include the image in the body of your ...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

The most likely cause is that you have selected the text of the list items, rather than the list itself. (I believe this is the default behaviour when you click and drag to select within a list.)

 

When you need to apply a condition to a list, or part of a list, I think the best way of doing it is to use the tag breadcrumbs at the top of the topic.

 

To apply a condition to a single list item, click inside the list item, then right-click on the li in the tag breadcrumbs and select Apply condition tags.

 

To apply a condition to a full list, click inside the list item, then right-click on the ol or ul in the tag breadcrumbs and select Apply condition tags.

 

Here is a screenshot illustrating A) condition applied to text B) condition applied to li tag C) condition applied to ol or ul tag.

Amebr_0-1648016368539.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

Hi Amber,

First of all, Huge thanks to you for the quick reply and helping me with the solution. 

The issue is fixed with the li tag and ol tag but I'm facing the same conditional tag issues in some other place. Under a style tag I have added few text and after applying conditional tag the text disappeared but the style remained.

 

Same issue like the previous one, the only difference is previous is with bulleted list and this issue is with the style.

I have attached the screenshots, please help me to fix this issue as well.

 

Thanks.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

The solution will be the same, just with a slightly different tag. I can't tell you what to pick though because I don't know what your code is like. Probably you need to pick the p tag, but as I said, it depends on the code behind the scenes.

 

A screenshot of the source that includes the tag breadcrumbs can help us help you, if you can't figure out the correct tag yourself.

 

Also, please use the Insert Photos icon to include your screenshots, as that will include the image in the body of your post and make it much easier to help. With attachments we can't see the text and image at the same time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

LATEST

Hi Amber,

Thank you once again for helping. I added that spectific section under div tag and it worked fine. For bulleted lists I followed as you said it worked too. Thanks alot for your support.

 

Have a good day.

 

Thanks,

A

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp