Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


CSS Issue in Robohelp Responsive HTML5 Output

Community Beginner ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

I've encountered a confusing CSS issue in my Robohelp Responsive HTML5 output that I cannot seem to resolve. In the images below, the top image represents the correct CSS styling as presented in RoboHelp. The bottom image represents the actual responsive HTML5 output. As you can see, the font and bolding are missing in the output. I am only dealing with CSS issues in one section of my project. Does anyone know what I can do to resolve this? I've tried manually altering the CSS in the layout.css file to no avail.

Thanks

TOPICS
Classic

Views

313

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Without looking at the underlying HTML code and the CSS it's impossible to say anything.

Can you post the part of the HTML code from the source file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Stefan,

I actually just solved the issue on my own. Thank you, though!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2019 Feb 04, 2019

Copy link to clipboard

Copied

Can you post your solution? It might help people in future.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2019 Feb 05, 2019

Copy link to clipboard

Copied

LATEST

Sure!

I'm not sure how broad this issue may be, but in this specific case, my browser console log indicated that it could not find the correct CSS file, which is why the bolding and font were incorrect in the output. It was trying to reference a file that did not exist within a specific folder location in my project. So, I created the CSS file it was referencing, adding it to the correct folder location, and included the CSS necessary to bold and modify the font style. That solved it for me!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation