Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Different Searchresult between webhelp generated in robohelp 2017 and robohelp 2019/2020

New Here ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

I am working at PengVin Affärssystem AB (Sweden)
We have recently upgrade from robohelp 2017 to robohelp 2020

We build the project as WebHelp / Responsive HTML 5

 

I have found that the "searchengine" in 2019/2020 does not receive the expected number of hits.

sometimes the difference is very large compared to the old.

 

For en example:

Searching for the word "Ordererkännande" (=order acknowledgement)
you got 29 hits in the old build

webhelp_prod_Searchresult_ordererkännande.png

URL for test:
https://webhelp.prod.pengvin.se/webhelp2020/PengVinHelp.htm#Order/Orderregistrering_Q.htm

 

In the build from robohelp 2019/2020 you got none result .
PengVinHelp (listen2music.se)

The content in both cases is the same


If you search for the word "Fakturor" (=Invoices) you got even worse differences
94 hits in the old build and only 4 in the new build

If you search for the word "Faktura" (=Invoice) you got 
118 hits in the old build and only 149 in the new build

and so on...

 

In robohelp output we have these settings for search

robohelp_2020_outpuit_searchtab.png

 

Views

340

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 09, 2021 Jun 09, 2021
I am advised that this will be fixed in Update 5 which is planned for tomorrow (10th June). ________________________________________________________ See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

What point versionof RH2020 are you running? Check to see that it's using Patch 4 (2020.4.xxx)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

We have recently upgraded to 2020
We Are running 2020.4.173

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

worth mentioning is if I build a Microsoft HTML Help (chm) from 2020 I got the same result as in the old build

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Try experimenting with a new (not copied) output Preset for HTML5.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

I have now tried to create a new output preset

And tried to expriment with a several different options in the searchtab but nothing get a reliable searchresult compared to the old build, the old one is the one thats give the correct answer.
What more could I expriment with?

I also found that in the example above when searching for "ordererkännade" that gives none result.
If I search for "ordererkänna" (which it not a correct term at all) I got in this specific case a correct answer

KristofferKajlerWard_0-1622623097926.png

while the search for the correct term gives

KristofferKajlerWard_1-1622623198345.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

The problem is a bit more bizarre than you describe. I found an instance of Ordererkännande by poking around and then I accessed another topic from the TOC. See these images.

 image.png

 

image.png

 

Try creating one of the frameless outputs and see if you get better results there. 

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

 

 

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Frameless output from our project can not be search at all

nothing happened no matter what you are searching for.

Välkommen (listen2music.se)

KristofferKajlerWard_0-1622632925802.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Is it working in the locally generated output and only failing on the server when you publish or upload?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

It is the same behavior in the locally generated output as on the IIS-server.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Can you share the project? If you can, then see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

I have uploaded the entire project in a zip-file here:
http://www.listen2music.se/uploads/filer/PengVinHelp_rh2020_Krka.zip

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

I am getting the same results and have taken this up with Adobe. They will either reply here or to me in which case I will update the thread. You can remove the link if you want to.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Which case did you take futher to Adobe?
Incorrect search result in Responsive HTML5 or Searching in Frameless output or both?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

I reported the number of search results but they have the link to the whole thread. Let's see what comes back.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

I just spotted that in Assets > JS there are a number of files that start WH. That suggests you have imported some output topics and I think I saw a post where that did cause issues.

 

Do you recall importing any topics from an output?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

By searching on the file names I found you had imported six output topics that had been imported. Unfortunately deleting those topics has not fixed the issue.

 

I also found the highlighting I had seen was in fact the browsers find highlighting.

 

Whilst not relevant to this issue, I noticed quite a few topics are not in the TOC. I wonder if you are aware that in 2020 topics only get into the build if they are in the TOC? If you don't want users to see them in the TOC, add them and then click the Hide in Output check box in the TOC properties.

 

Hopefully Adobe will find the issue.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

In an earlier post I suggested you removed the link to the project. You seem to have removed the download so Adobe will not now be able to download it. 

 

Ignore the request to upload again, I will get the original zip to Adobe.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

Thank you for taking the time to look to our project!

 

I have recently taken over the project from another employee who is not currently working. 

So I do not know everything that has been done in the project over the years and working in robohelp is pretty new to me, working with development, usually I work as a developer. But the company has worked in robohelp serveral years, I assumes that what is not included in TOC is not relevant to include.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

Wrong assumption. In Classic versions everything in the project was included unless build expressions were used to exclude topics, in the new UI it is the other way around. Nothing is included unless it is in the TOC. That is explained here. There is a big change in what goes into an output. The change means that some topics are not going to get into the output and that will cause broken links. The Topic List report will show you which topics are not in the TOC.

 

You also need to clean up the output topics that have been imported. As far as I can see they are not affecting the issue reported here but they will likely cause other issues. Post a separate question on that later when Adobe have looked into this issue.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

I am advised that this will be fixed in Update 5 which is planned for tomorrow (10th June).

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Thanks for fast response.

Now it works great!

And also thanks to the adobe team who fixed the issue!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Hi there,

I have made the experience that the setting "Auto correct search query" leads to quite strange search results in German language, so maybe this is also the case in Swedish. Maybe you could try if the results look more reliable with this setting turned off.

Best regards
Karin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

@Karin Albrecht Search has changes in Update 5. I wonder if they would help your project.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

LATEST

@Peter Grainge I will sure run some tests regarding search with the new update in the next couple of days.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation