Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


failed to generate word

New Here ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Good morning,
I have robohelp 2019 and word 2013 and cannot produce the correct printed documentation. It gives me error `` FAILED TO GENERATE PROVAWORD.DOCX ''. I would like to see the steps that the program performs but I don't know where they are. PDF instead does. What can I do?

Views

211

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

The forum system has given you default name, you can set up a better name if you edit your account settings. It doesn't have to be your real name.

 

Are you using 2019 Classic or 2019 New UI?

 

Have you tried generating on of the sample projects to Word? That will tell us whether the problem is your setup or your document.

 

  • In Classic versions, click Open Project on the RoboHelp Starter page and then click Samples in the ribbon on the left.
  • In the new UI you should see them on the Starter Screen but if not then click Open Project on the Starter Screen to open File Explorer. Browse to Documents and then My RoboHelp Projects.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

Good morning Peter,

Happy new year.

I tried to make a new project with two topics and turn it into word. It works but the word has huge style formatting. So I tried again with an old project that gave an error but I created a new smaller table of contents and tried to produce a word document. I managed to get a word but with the same problem of gigantic characters. I think the problem is the styles.
I think I have robohelp 2019 classic ... in the project information it says Adobe RoboHelp 2019
2019.0.10.

I know I'm not very competent and I apologize for this ... but in Italy I don't find anyone who takes courses to learn better.

best regards

daniela

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

Peter,

Maybe I understand .... as I thought if I use a default .css standard and when creating the word I put all the parameters of the styles '' style mapping  = discard style'' works correctly. Otherwise, if I use a custom css with some variables for the styles and when creating the word I put all the parameters of the styles '' style mapping ' = discard style''  works. Probably the variables do not allow a correct creation of the word document.

It's true?

daniela

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

In your other thread, you mentioned running RH2019.0.10 - I think that's slightly out of date. Try updating it by using Help > Updates or go to https://www.adobe.com/support/robohelp/downloads.html to grab the latest version of RH2019. Then try what Peter has suggested on the sample projects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

First of all please reply via the web and use the Blue button, otherwise posts get out of date order and it can become a nightmare following posts in date and time order.

 

The version numbers don't help identify your version as both Classic and the new UI used the same numbers. We have to establish that first. Does your version look this this?

 

New UI

image.png

Or like this?

Classic.

image.png

 

Then according to which version you are using go to Printed Output (grainge.org) and click the link to the page for the version you are working with.

 

If that doesn't help, post back here and include some screenshots of what you are seeing. Please use the photo icon to insert images within the post. Some supporters will not open attachments for security reasons and if you do download, you are then not seeing the image inline with the text. Then thanks to a quirk of this forum you have to close the thread and reopen it before you can reply. Crazy but that's the way it is.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

tks peter,

i have new user interface 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

If you want me to help you, please note what I posted earlier. The posts in this thread are getting out of order make it difficult to see what is a reply to what. You are either using the Black reply buttons or replying by email. The latter does not sort things into the correct time order.

 

First of all please reply via the web and use the Blue button, otherwise posts get out of date order and it can become a nightmare following posts in date and time order.

 

Dependent on how you set up the preset you get various mapping options.

 

If you leave the master page and Word template fields blank, in this dialog you will see just two options.

 

image.png

 

With that setup, you will get the styles in your topics or a default style.

 

You will see the same options if you select a master page with a different CSS linked to it. In this case the RoboHelp styles will be whatever you have defined in the CSS linked to the master page.

 

If you define a Word template, the styles in that will additionally show in the dropdown.

 

Please clarify what settings you are using and what is going wrong.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Peter,

I did exactly as she told me.
and I also tried to put a word template but in any case it keeps giving me error on the header 3. The characters on word are huge. in summary, there are two problems:
if I use the custom css with the variables the process of transforming the help into word does not work
if i use a default css the process works but if it finds a heading 3 the characters on word are huge.

tks daniela

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

I did exactly as she told me. Who is "she"?

 

Can you share the project? If you can, then see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

If you can't share this project, create a new project with just one or two topics and recreate the problem there using the same CSS, then send that.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 11, 2021 Jan 11, 2021

Copy link to clipboard

Copied

You are not helping me help you. I asked you to send an email by clicking the link on my Contact page on my site. I have downloaded your project and right now it is not generating a Word document. I think I know why but I need some information from you.

 

Please email me and include a screenshot of a topic in RoboHelp and what it looks like in Word. Include the filename of that topic and then I can look into it for you.

 

I am asking you to do this direct as it is much easier to have the dialog that way. Private Messages do not allow screenshots and various other restrictions mean that email is much easier. Most people do not want to post the contents of their help on the forum, hence asking you to start an email dialog.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 11, 2021 Jan 11, 2021

Copy link to clipboard

Copied

Using your Short TOC the topic generates OK and looks fine. That's why I need those screenshots so that I can see what you are seeing and saying is wrong.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

LATEST

I found two basic issues in the project.

 

One was list styles not upgrading in a way that could be "translated" into a Word document. The CSS was very old containing kadov tags as older readers will recall. Also I don't think I have seen so many list styles in one CSS. I'm not too surprised it caused issues in Word.

 

The other was some very odd code in a topic added after upgrading so not an upgrade issue.

 

Daniela is now working on the CSS and the topics.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp