• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Global Find and Replace in RoboHelp 2020 Not Showing Topic

Explorer ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

Hi, I am trying to perform a Find and Replace across all project topics in RoboHelp 2020.5.71.  However when I receive the matches, I see no way to open the topic itself to see where the match exists.  I would like to open the topic from the results list to see the context of the search term.  I do not want to blindly replace something.  Am I doing something wrong?  Is this a bug or is this working as expected?  These are the steps to reproduce:

  1. Click the Find and Replace icon.
  2. Specify a Search term in the Search field.  Specify the' Replace with' field (I tried not using this and it still doesn't work).
  3. Select Topics from the Files of Type field.
  4. Select Current Project from the 'Look in' field.
  5. Click the Find All icon.
  6. The 'matches' are returned in a list on the bottom of the Find and Replace panel.
  7. The presented options are Previous Match, Next Match, Replace this result, or Remove this result.
  8. The topic where the first result was found does not display in the authoring area.  If you try to double click on the result in the list to view the topic, an Application Error message is displayed.  Shouldn't there be a way to open the topic from the results list to see where the search result was found, so that you can view it in context?  Is there another way to perform a global Search or Search and Replace across all topics where the topic opens for review?  I thought RoboHelp 2015 used to work that way.

WiscoLori_0-1624917867044.png

Thank you,

Lori

TOPICS
New UI

Views

172

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 29, 2021 Jun 29, 2021

Sorry, I misread.

 

I'm not sure what to suggest on this one but try this first.

 

  1. Create a copy of the project first.
  2. Delete the contents of the .rh folder in File Explorer.
  3. Try again.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate
Community Expert ,
Jun 28, 2021 Jun 28, 2021

Copy link to clipboard

Copied

I can't reproduce the error you're getting. For me, double-clicking on the file name does nothing, but double-clicking on one of the matches within the file opens the topic.

 

Can you reproduce the error using one of the sample projects (should be in your Documents > My Robohelp Projects folder)? This should indicate if it's some problem with your project, or an installation problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

I get a response like this. If I double click one of the highlighted results it opens the topic with the word highlighted. The refresh icon to the right shows has a tooltip Replace This Result.

 

image.png

 

Instead you are getting an application error so as Amber has suggested, try another project.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

I just tried it in the sample project, and clicking on a search match in the list opens the topic and highlights the search term.  But when I do that in my project, I get the Application Error.  Any idea of what could be causing it or what I can try?  This is a project that was converted from RH 2015 to RH 2020.

Thanks,

Lori

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

So as suggested earlier if you get this problem with the sample project, there is an installation issue. First thing to try is uninstall and reinstall with admin rights. 

 

I am assuming you are using a 64bit machine with Windows 10. If so and reinstalling still fails, contact Support. See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your support contact options.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Thanks Peter.  I'm not getting the problem on the sample project, just my project.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 29, 2021 Jun 29, 2021

Copy link to clipboard

Copied

Sorry, I misread.

 

I'm not sure what to suggest on this one but try this first.

 

  1. Create a copy of the project first.
  2. Delete the contents of the .rh folder in File Explorer.
  3. Try again.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

I've had this happen also, and for me, the problem has always been some incorrect HTML in the topics I'm trying to open. That has happened when I previously did a search/replace all in the code for something I didn't like, such as 

<span>Some text that doesn't need to be in a span.</span>

If I replace the opening span tag with nothing, then it leaves the closing span tag without a matching open tag, which causes the application error when I try to open the file in Authoring view.

If you can, open an HTML file in a plain text editor to see if you can spot some closing tags without matching opens (or vice versa).

Hope this helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

Thanks for the tip Karen!  I will have to review the HTML in the results list and see if I spot any errors.

Lori

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

LATEST

Update:  I finally got around to trying Peter's suggestion of deleting the .rh file, and...it worked!  Thank you so much Peter.  🙂

 

Lori

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp