Hypertext links between children projects

Community Beginner ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

Hi there,

I'm running Robohelp 2020.6.76 and I've created a parent and 2 children. Is it possible to create a pertext link between the 2 children?  I have an abbreviation list in 'child A' that I reference in 'child B'. I'd like to add a hypertext link in 'child B' to the abbreviation listing in 'child A'. Is there a way to do this?

Thanks,

Carmela Wilbur

Views

151

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

I assume by "pertext link" you mean "hypertext link". See Links Between Child Projects on my site.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

I was going to suggest that the OP check out your site on merged projects 😂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

Peter,

New riddle-- I added the link from topic in child A to topic in child B like your website says.  When I'm in child A, and I do a preview, the page works. However, when I generate the output preset (frameless), I get a warning that it skipped copying the external file. The message says Warning, skipped copying external file and then gave the full path of the file.  So, it found the file, but didn't use it??

 

So, I'm not sure why this link worked in the topic preview, but not when I generated the OP? And it looks like the OP found the file, yet it didn't copy it. 

 

FYI -- When I go to the OP preview and click on the link, it says page cannot be found.

 

Thanks for your help, have a great day!

Carmela

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

Thank you. Let me clarify -- I want to create a hypertext link to a topic from Child A to Child B.  

 

I have a topic in Child A, that is referenced in Child B -- can I link at the topic level between the children?

 

Hope that helps to clarify.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

Nevermind, I got it!!!!  

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

That sounds like you have created the link using the wrong option in the dialog. Did you use project files or local files as shown?

 

The link will work in preview either way as at that point the URL is correct. However, it is not when you generate.

 

Download the sample project and upgrade it. You will see there.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

I used local files:

 

cwilbur_0-1646844957887.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

Thinking some more about this I think you will see that when you generate.

 

Generate the parent first, then all the child projects, then open the parent and test the cross project links there.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

no it still isn't working. I've backed out of the hyperlinks, and I'm having issues publishing. So, once I get it to publish without the hperlinks, I'll try to publish with the hyperlinks. Then I'll see if it works. 

Thanks for following up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

I really think it would help you to download the demo and see it working there.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 18, 2022 Mar 18, 2022

Copy link to clipboard

Copied

Yes, I downloaded your demo and the only difference tha tI can see is that I'm using a Frameless_Studio skin and you don't have that loaded as an Output Preset.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 18, 2022 Mar 18, 2022

Copy link to clipboard

Copied

  1. Are the links working though when you generate the demo?
  2. Assuming they are, have you compared the code in the demo with your code? 
  3. You can soon add the Studio skin to the parent. In a merge all the child projects use the same as the parent. You don't have to add the skin in the child projects. Just generate the parent again. That should work but generate all again if not.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

yes, the links in the demo work.  I'm using a frameless skin, does that matter?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

No the skin does not matter. The fact that the links in the demo work strongly suggests one the two things I have suspected.

  1. Your source projects are not structured the same way as the demo. It is important that the parent is in one folder and all the child projects are in another folder. The parent is off the root so that when you click on the folder, you see the rhpj file. The children are then in a second folder off the root called children or whatever you want. The key bit is to get to the rhpj file, you have to go one level deeper.
  2. You are not creating the links as I describe.

 

I'm pretty sure it is (1). Using that structure the relative paths are correct and work, any other structure they will not work unless you manually edit them. Look at the links in the demo and yours. They will likely be different.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

I'm trying to re-create based on your file structure in the demo. However, I used compass travel, and then when I got to the RoboHelp Projects I broke it down into parent and children folders. I did this because I need folders for images, documents, etc. your demo doesn't have those folders.  If  I follow your demo - with my content, where do I add images, documents, etc.?

 

I think I'm linking the children correctly, becasue it works in preview. The error happens when I generate. And it doesn't matter if I generate the children or parent, or what sequence of generating I use, the error occurs. It occurs on both of the children and the parent.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

You create the topics, images and so on in the respective projects. At this stage think of each project as self contained.

 

The fact it goes wrong when you generate screams at the issue being you have still not got the structure right.

 

In File Explorer when you click on the parent on the left side, you should see the rhpj file and the various folders for that project. When you click on Child Projects, you should see folders for the child projects.

 

  1. Create a folder such as MyMerge.
  2. Copy the Parent project directly into it so that when you click on that folder you see its RHPJ file.
  3. Create a folder for the child projects and copy the folder for each project into it. You will only see the RHPJ file when you click on your equivalent of Child_One etc.

 

image.png

 

If you still cannot create the cross project links, can you share the projects? If you can, then see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the projects direct.

 

What I need you to send is a zip of the MyMerge folder equivalent so that I can see your structure.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

 

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

LATEST

The other possibility is that you are not generating to the correct folders. When you generate the parent a folder is created called mergedProjects. That has sub-folders for each of the child projects.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp