Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


I am receiving consistently a Javascript error in the use of image maps with links as an automatic popup to a topic (html file). The error states "An error has occurred in the script on this page. Error: 'BSSCPopup' is undefined. Code: 0 What can I do?

New Here ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

I am receiving consistently a Javascript error in the use of image maps with links as an automatic popup to a topic (html file). The error states "An error has occurred in the script on this page. Error: 'BSSCPopup' is undefined. Code: 0 What can I do?

My image maps linked to a html topic work if I use "Display in frame".  They do not work any longer in RoboHelp 2015 (updated with ALL patches) when I use "Display in auto-sizing popup" or "Display in custom-sized popup" where JavaScript is used. Any ideas? Must I have JavaScript installed to work as the scripting language in RH2015?  My IT Team says I never had it before, only JAVA.

TOPICS
WebHelp

Views

243

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 31, 2017 May 31, 2017

Copy link to clipboard

Copied

WebHelp depends on JavaScript being enabled - but this isn't the same as Java - that's completely different & WebHelp doesn't use it. Where are you examining the output? On a web server or your local machine or LAN server? What browser(s) are you trying?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2017 Jun 01, 2017

Copy link to clipboard

Copied

Hi there. I am viewing the topics that include "popups" that are either auto sizing or custom sized from inside RoboHelp 2015  using the "View item" function from inside the Edit ribbon.

I did discover all of the popups work fine when the project is generated and published using Internet Explorer 11.  Did the popups  always not work when viewing a topic inside the RH project??? I am thinking JavaScript error is trying to state it cannot find the location of the topic I am linking to within the popup.  But obviously it is not true, or I could not use them in the published version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2017 Jun 01, 2017

Copy link to clipboard

Copied

I did notice I have all of the current RH2015 "patches" installed and I tried viewing using Google Chrome browser. Although it did not work, I did have a blue bordered box display around where each popup occurs when "viewing" using Chrome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 01, 2017 Jun 01, 2017

Copy link to clipboard

Copied

LATEST

Viewing or previewing inside RH doesn't always represent what you're going to get once you generate - don't rely on it to get an accurate representation - do the generate function & examine the output folder outside of RH.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation