• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Import .docx menu document and generate a help menu based on the .docx

Community Beginner ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

 

Hi, Peter,

 

I'm trying to import .docx menu document and generate a help menu based on the .docx.

 

The import process: 

I chose the following:

Convert references to hperlinks

Convert table of contents

Convert index

 

Then used webhelp to CHM to generate CHM file.

Although it has the table of contents and hypger link, the index and search function don't work.

 

Would you please help me out ?

 

Thanks,

 

Lily

Views

189

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Your version of RoboHelp? 

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Also what do you mean by Menu document? 

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Robohelp 2019

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

I'm trying to convert a user menu of software application to .chm file so that when press F1 in the software application, the help menu content will show with search capability.

Thanks,

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

As you are using the WebHelp to CHM converter script, you must be using 2019 Classic.

 

Does the webhelp work OK?

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Hi, Peter,

I'm using Robohelp classic 2019.

The .chm file search function seems not working.

After opening .chm file:

When clicking Index, and type in any keyword, nothing comes up.  Please see the snap shot.

Lily5FFC_1-1599660216624.png

 

When clicking Search, 

Lily5FFC_0-1599660150734.png

there is an error occured as the above snap shot.

Clicking on search again, 

type in search keyword, nothing comes up. 

Please see below the snap shot.

Lily5FFC_2-1599660286805.png

 

 

What is missing to make the index and search working please?

 

Thanks,

 

Lily

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

I don't know yet. That's why I asked if it works in the webhelp you have to generate first.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

I used webhelp to CHM to generate .chm file.  Not generate webhelp first yet.

Do I have to generate webhelp first?

 

Thanks,

 

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

The script is Convert WebHelp to CHM. If you don't generate the WebHelp, how is the script going to convert it? ☺️

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

I tried to generate webhelp and convert to .chm file before.  It was the same result.

The index is still empty.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Did the WebHelp output have a working index and search feature? Are you all patched up? Check Help > Updates to check.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

WebHelp output doesn't have a working index and search feature.  

My update option is disabled since it is corporte license.

What patches need to be updated?

Thanks,

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Well, if the WebHelp output isn't working, then the CHM coming out of the convertor script won't have any chance to work either! Better to have a look at what's going on in the RH project first before looking at the output. What point version of RH2019 are you running? There have been 14 patches issued.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Lily5FFC_0-1599675551395.png

This is my version

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Ok, you're a few behind - get your IT people in to run the updater process - if they can't enable it within the software, go to https://www.adobe.com/support/robohelp/downloads.html and download the patch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

what I need is RoboHelp Classic 2019 update.

The link I got seems to update Robohelp, which has totally different GUI interface which is not the RoboHelp Classice I'm using.  Do you have the link for Robohelp Classic please?

 

Thanks,

 

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

It updates both versions. What is Classic showing? Was the update applied by someone with admin rights?

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Lily5FFC_0-1599681896185.png

My IT person told me I was on the lastest version of Robohelp Classic.  He used Admin right, there is no more update available.

So what's next? 

Is there any selection I didn't do to cause the index and search feature not working?

 

Thanks,

 

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

My IT person did take a look at the version.

The next update is RoboHelp 2020.

We have the RoboHelp2019 the last update.

Even if he run as admininstrator, the update is grey, which means there is no update?

Anyway he is saying I have the latest version of Robohelp 2019 classic.

What are the options to choose when generating webhelp?  What is index supposed to be searchable?

Can I show you what I'm seeing?

How would the search function work?  when type in a word, my document title comes up.  On the right pane, scroll down, can see multiple highlights for the word, but not in the left pane for the finding results which I'm expecting.

This is really hard for you to understand what I'm seeing.

Is there any way to be visually available for effective trouble shooting?

Thanks,

 

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

They would be wrong - I'm just updating a copy of mine right now & it's doing  14.0.14 right now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Ok, mine just finished - I'm now at 2019.0.14 - did your IT try using the link to the patches that I posted?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

Is the search function normal when put a keyword, only 1 title found with the document name on the left pane, on the right pane, there are many highlighted keyword found?

 

Thanks,

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2020 Sep 09, 2020

Copy link to clipboard

Copied

If the word is only found in one topic, but the word appears many times in that topic, then yes, that is correct behaviour. 

 

For example:

Amebr_0-1599699781449.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2020 Sep 10, 2020

Copy link to clipboard

Copied

Lily5FFC_0-1599743807070.png

Why first time run search, there is the above error message?

 

Thanks for reply in advance,

 

Lily

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp