Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Link to the homepage of parent project RH2020.4

Community Beginner ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

Hello, everybody! I use RH2020.4 and face the next problem. I have a parent project with few children ones.

Andrey5E7F_0-1622786893311.png

Once I publish my site on a server, everything works well except the logo link of children's projects. Please, see the video in the attachement. I guess this link is to children's index.html, meanwhile, I can see absolutely correct URL in the address line. Undoubtedly everything works well on my local PC :).     

 

 

TOPICS
New UI

Views

82

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

In the output TOC when you click the icon for a child project it opens whatever has been designated as the default topic in that project. 

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

 

 

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

Is it possible to redirect this link to the index.html of the parent project, or just use the domain name here? It is not clear why it works well on local computers and why I can see the correct link to the parent project in the address bar of the browser.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

I don't think it is and very much doubt it would work satisfactorily. That would open the child project within the topic area so you would have a project within a project. That would screw up searching and other features. They would be trying to work standalone and the child project outputs are now generated differently compared with how they worked in Classic versions. There you could copy a child project from mergedProjects and it would still work on its own, that is not how it works now. See You cannot run the child projects standalone by copying from the merged output.

 

As to why things are working for you locally, I am not sure.

  • First of all put a copy of just the output in another folder and see if it still works and/or try it on another machine.
  • It may also be because your setup is a bit different. I avoid content in the parent project as that can cause parent/child links to break.
  • From the video it's not really clear what is going wrong. Please describe it.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

The problem is: that if the user goes to the child project, he can't return to the main page of the parent project when he clicks the logo. And this would be more than logical with such a structure.

 

Moreover, when I click on the logo of the child project, I see the correct address in the browser command line, but the transition to the main page does not occur.

 

And this problem only manifests itself on the server. When I work with files on my computer, I can go to the parent project's home page.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 04, 2021 Jun 04, 2021

Copy link to clipboard

Copied

LATEST

Yes that is how it should work and it looks like something may not be getting uploaded properly.

 

If you go to www.grainge.org/demos/merge you will see a merged output. It has some rubbish content as it was a project I was testing with. However, it should work as you expect. If it does, there is a clean version of a demo set up at the demo. Open each project and upgrade to the current version, then generate the presets. Put the merged output on your server and see if it still works.

 

I don't have content in the parent but I don't think that is the issue here. The logo top left should always go to the parent default topic. Also the TOC should also show the parent projects topics.

 

It has also just occurred to me to ask if you have defined the URL for the logo. However, if that is it, I am wondering why it works locally.

 

image.png

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation