Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Mini TOC is not displaying contents

Explorer ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

 

Mini TOC is not displaying contents. When I publish to SharePoint Online I get the following message when I click a heading in the Mini TOC:

 

The webpage at https://tmobileusa.sharepoint.com/sites/RoboHelpOnline/Shared%20Documents/PIER_2/undefined#rearrangi... might be temporarily down or it may have moved permanently to a new web address.

 

This happens with all Mini TOCs in the file that has been upgraded from RH 2015 to RH 2020 as well as a newly created Mini TOC. These display just fine in the Preview.

Views

128

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

So the minitoc works fine when you view the locally generated help, but not after you publish to sharepoint, correct?

 

If so it suggests some configuration issue in Sharepoint.

 

Perhaps this thread can help. It mentions a number of Admin settings and permissions.

https://community.adobe.com/t5/robohelp/sharepoint-online/td-p/10603121?page=1

 

Let us know if how that goes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

I already have the necessary permissions. I wrote most of the comments on that page. So I need Tech Support to contact me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

Publishing locally a.png

Published to SharePointb.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

That "publishing locally" image - I assume you mean "generated and opened from the C drive". So that would indicate a problem with the project rather than sharepoint.

 

If you want to talk to support you'll need to contact Adobe directly as we're all volunteers here and staff don't generally look at the forums. https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp

 

(edit to remove irrelevant info)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

Also make sure you're on Update 3. If you're on the original release, you can't use Help > Check for Updates, but will need to download the latest update from here: https://www.adobe.com/support/robohelp/downloads.html

 

Once it's installed Check for Updates will work as normal.

 

And can you try adding a minitoc to one of the sample project and see if the error occurs with that? That will help determine if the problem is isolated to your project or not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

Thanks for all your input, but there is nothing wrong with the file. This happens with newly created files as well. There is a bug in the Mini TOC. I have contacted Adobe support and will keep you posted on their findings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

I'm inclined to think it is a URL issue so it will be interesting to learn what Support come up with.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Have Support resolved this for you?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Always a shame when someone seeks help but then does not come back with how they resolved it if the answer couldn't be found here. Publishing solutions is what makes the forum tick.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

Publishing solutions is what makes the forum tick if anyone actually helped me solve the problem. I have had no help from support in spite of numerous attemps by phone and email. They never replied. My solution was to delete all my mini tocs. And it is definately not a url issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2021 Jan 29, 2021

Copy link to clipboard

Copied

So why not come back sooner and tell us that? Did you get a case number as I can ask someone to follow it up?

 

At the beginning you said it worked in preview. Did it also work if you generated the output locally or is that what you meant by Preview.

 

The link you have posted is not accessible to forum users.

 

There's a couple of questions that Amber raised, let us know about those.

 

Do links in the TOC work?

 

Could you publish a new project there with just a few topics to test a project created in 2020? Mini TOCs work as you can see at About Adobe RoboHelp (grainge.org).

 

Please let us know either way whether or not you want to try a bit more to get it working and, if you do, then please respond to the above. That's the only way we can help here.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

This is not a problem that the forum can solve. It is a bug in RoboHelp. I have been working with Adobe to get this fixed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

LATEST

Well, let us know what Support came up with - it can only help others who may run across the same issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp