Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Need help finding information about a closed bug

Contributor ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Hi,

 

In February 2018, I filed a bug with Adobe about a search issue with RH 2017,  Search doesn't work properly when a search term contains the % character  (RH-1377)

 

In December 2019, I received an email saying it was fixed.  There was no indication of what version it was fixed in, except "update 10".  Update 10 of WHAT?   

 

Yesterday, I downloaded a trial version of RH 2019 to test a few things, including this bug and another bug I filed.  So, I upgraded my RH 2017 Responsive HTML project to RH 2019 Classic, and regnerated the doc.  This bug does not seem to be fixed!  However, the text of the email suggested I needed to define some parameters.  

Can anyone tell me where to find "Preset -> Search Tab" from the Adobe's comments :

 

We have fixed this issue. To fix this a checkbox and a text field are added in the preset->search tab. The text field contains characters that should not strip off while stemming and indexing the words.

 

This text field contains numbers, delimited by semicolons by default.

 

The checkbox is there to show or hide the text field. Irrespective of its selection, the characters in the text field will not be stripped from the words in topics.

 

You can add characters in this list separated by semicolon as per your need. Fix will be part of update 10.

 

Kindly give it a try and do let us know how is goes at your end.

 

 

Views

224

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Contributor , Jun 18, 2020 Jun 18, 2020
I think I may have grabbed the wrong/old installer folder......from a previous attempt at installing RH 2019.  I'm going to uninstall and download it again.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Update 10 can only apply to RoboHelp 2019.

 

In 2019 you will see two tabs top left. Click Output. There you will see all the presets, effectively the same thing as the SSL layouts in Classic.

 

Lots of information about 2019 in the RoboHelp Reimagined sample project and the RoboHelp Tour on my site.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Thank you for the quick reply. 

 

I totally admit I am completely lost on the RH 2019.  Where the heck are all the baggage files? How can I see the Project Manager pane AND the TOC at the same time?  I need to watch some tutorials.     Anyway.....I don't have time to figure it all out before my next deadline, so  I'm very happy there is a Classic option.  

 

On both the 2019 new and classic versions, I still do not see any options described in the Adobe comments.  What am I missing?  

 

In the 2019 new layout, I don't see a new text field and checkbox added or list to manage:

JGaf_1-1592493875382.png

 

In the Classic, same thing:

 

JGaf_2-1592493976941.png

 

 

 

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Sorry but I can't look at the bug issue right now. I doubt the issue will have been fixed in Classic.

 

Yes 2019 New UI is hugely different so you are going to have to do a bit of reading. Links above.

 

To view TOC and Contents, in TOC panel double click the TOC so it opens in the large authoring area or right click the TOC and select Edit. Then click Contents on the left toolbar.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Thank you.  No problem, I know you're busy.

 

I have no idea who to call or email about this.  I posted another comment to the bug, but it is marked Resolved, so I don't know where that will go.

 

Also, I thought the only difference between the 2019 new and classic versions is the UI. 

 

From the FAQ:

The RoboHelp (2019 release) installer installs both RoboHelp (2019 release), an all-new application, and RoboHelp Classic (2019 release), which retains the experience of older versions of RoboHelp with updates. You can migrate existing RoboHelp projects into RoboHelp (2019 release). However, once you migrate and edit the projects, those projects cannot be imported back to older versions or RoboHelp Classic (2019 release).

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

It is a complete rewrite of the software, not just a UI stuck on top. Hence there are differences.

 

Can you briefly describe the issue here? That would help me.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Ah, you provided a link to the bug. So if a user searches with % in their search string and the content contains %theirstring, it gets found but the link doesn't work, is that it?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Yes this is correct,  The search term is found,  but the search results link does not work. Clicking on a search result link does nothing.  Users have to right-click to open the page in a new window, and then highlighting does not work.  Also, predictive search terms do not display when % is used in the search field.

 

Adobe said it's fixed.  They added a checkbox and text field to add special characters.   I can not find this new feature in RH 2019 (new and classic versions) and search remains broken when I use a % in the search terms. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

With %Peter% in a topic and this change in the Search settings, %Peter% was found when I added ;% to the end of the supplied list.

 

image.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

I can not find the checkbox and new text field.... where did you make the change ?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Are you looking in 2019 New UI? Top left when you open it there is an Output tab. In the Frameless and Responsive presets, it is in the search options.

 

Select the option shown and the characters will appear.

 

image.png

 

It hasn't been added to Classic, as I suspected and I doubt it will be.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

No, I do not have that option  under Responsive HTML.  

 

To be clear, I'm looking at RH 2019.0.7

 

I also created a new Responsive HTML output, and I see the same options there too.  

 

JGaf_0-1592508591029.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

I think I may have grabbed the wrong/old installer folder......from a previous attempt at installing RH 2019.  I'm going to uninstall and download it again.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2020 Jun 18, 2020

Copy link to clipboard

Copied

Your version is Update 7 and as you know, the fix was in Update 10.

 

Be careful what you update to. If you are going to be using Classic as well, do not apply update 13. There is a problem with Update 13 that affects Classic users only so OK if you will only use the New UI. Otherwise go for Update 12 as below.

 

1. Uninstall RoboHelp if you have applied 13 when you see this and reboot.

 

2. Go to https://www.adobe.com/support/robohelp/downloads.html and download Update 12.

 

3. Install that both versions will work and you will have the extra field.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 19, 2020 Jun 19, 2020

Copy link to clipboard

Copied

LATEST

Ok, well....that was the issue.  I used a previously downloaded trial version.

 

It's partially working, except now the search words are not highlighted when the search term contains a special character (and yes, the character is defined in the Search settings) and the page does not auto-scroll to the first instance of that search term.  

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp