Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


No page content following upgrade from RH2015 to RH2019

Community Beginner ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

I just upgraded (on a trial basis) from RH15 to RH19.

I updated an existing, fairly small project from the start screen. The dialog told me all went well. I then generated WebHelp output and viewed the output. The TOC shows nicely, but all of the pages show nothing more than a header.

Message was edited by Peter Grainge to show full version name. It helps others when they are searching.

Views

210

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Dec 19, 2018 Dec 19, 2018
I fixed the problem by creating a new master page. I deleted the old version, renamed the new version to match the name of the old version, and voila, everything displays as expected.

Likes

Translate

Translate
Adobe Community Professional ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

Select the skin again in the new version giving it a slightly different name. Does that fix the problem?


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

I tried that and the result is the same. If I launch Welcome.htm from a browser I see the page contents and can generally navigate my document, but it doesn't look "nice", so to speak. There are no TOC, index, etc. It's a fairly vanilla display.

I will go watch some tutorials on your site and keep working at it. I like what I see in RH2019 so I'm excited to learn more.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

That sounds like you are opening the default topic rather than the start page.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

Ah, yes. My mistake.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

In the editor I am able to edit my pages as expected. When I click on the 'preview' button all I see is the header and the footer from the master page.  The header is at the top of the preview page and the footer is immediately below it. I can examine the html by clicking on the 'source' button and I see everything I would expect.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

As an experiment, I removed the <meta> tag that points to my master page. When that tag is removed I can review the page (without the header and footer, of course). So, there seems to be an issue with my master page.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

LATEST

I fixed the problem by creating a new master page. I deleted the old version, renamed the new version to match the name of the old version, and voila, everything displays as expected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation