• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

One-Trust Cookies banner script gives strange result.

Explorer ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

Hi,

I added One-Trust script for cookies banner and the output gives some unexpected results.

Main page doen't display the content and in topics there is additional content.

This is the script:

<!-- OneTrust Cookies Consent Notice start for help.english.com -->
<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="a5bb5a1c-e336-40f5-9902-2413499c0da8"></script>
<script type="text/javascript">
//<![CDATA[
function OptanonWrapper() {}
//]]>
</script>
<!-- OneTrust Cookies Consent Notice end for help.english.com -->

Screenshot 2022-07-11 at 15.51.07.pngScreenshot 2022-07-11 at 16.01.08.png

 

Did anyone have a similar issue? Do you see any obvious mistake in the script?

Views

74

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

I don't know if it is the same issue and I certainly cannot comment on the script. However, I had a similar issue with a script I was given to inject into some topics. I went to the people who provided the script and told them it was not working in topics that were HTML5 and CSS3 compliant.

 

They provided a different script. Perhaps you could go back to where you got your script?

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

OK, thank you Peter, I will 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

Hi @Peter Grainge,

Along the issue with cookies banner from One-Trust vendor, my website started to not respond - blank homepage, with skin background only.

After removing the cookies banner completely - this issue remained. One-Trust returned to me that the issue was now on their side. Only when I turned off the GDPR option - website started to work, url: help.english.com

Wondering what can be the reason and how to make GDPR on again, as it is legal a requirement, and then I will need to implement cookies banner again. I found also that GDPR should be activated to have the cookies banner working, is that right?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

correction - One-Trust returned to me that the issue was not on their side.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

I don't know for sure about needing GDPR for cookies but I would expect it is required.

 

Turn it on in the skin editor.

 

image.png

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

Thanks @Peter Grainge yes, I know how to turn it on. The problem is that when it is on, the home page is empty.

Screenshot 2022-07-15 at 12.53.38.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

LATEST

Sorry, I misunderstood. I think you will have to take that up with Support. See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your Adobe Support options. The email link tcssup@adobe.com is recommended as it reaches a team dedicated to Technical Communication Suite products including RoboHelp. 

 

The only other suggestion is try a new skin to see if all the changes you have made are causing an issue.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp