• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

"Dynamic filters" don't appear on RH frameless output.

Participant ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

Hello, I'm trying to use Dynamic filters for RH 2019 Frameless output, but it doesn't apply on the output. Is there a way to show the filter or steps for how to do it?

 

Thanks.

TOPICS
Output presets

Views

449

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

You can generate the Learn a Latte project to see it in action. It should be available in your Documents folder under "My Robohelp Projects" (I think). The filters aren't available until you drill down to a topic.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 24, 2020 Mar 24, 2020

Copy link to clipboard

Copied

I found the answer on @Peter's site. I was missing the info that dynamic filter is no longer attached with condition expressions like before.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

I'm trying to create a filter in a frameless output. If the dynamic filter is no longer attached to a condiiton expression, then how do I create the dynamic content filter? The only trianing I've had included the condiiton expressions. I'm on Robohelp 2020. Thanks.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

@cwilbur Using expressions disappeared with the new UI. See RH2020 Dynamic Content Filtering (grainge.org). You can only use tags. Yes I know it limits what you can do and i know it makes some filtering impossible.

 

Maybe it would help if someone else creates a feature request. Please follow this link to report bugs or request new features. https://tracker.adobe.com. Post the link to your bug report / feature request in this thread and others can vote for it. The more people who do so, the higher it gets prioritised.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

Peter, thank you for your response.

 

Just to clarify, are you saying that I can no longer filter based on different departments? For example, I have 2 departmetns with different systems. I want to have the participant click on their department so they will only see their system information.  Is this no longer possible?

I don't want to create 2 separate projects becasue there is information that is the same in both departments, and maintenance would be a nightmare.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

@cwilbur No that is not what I am saying. You can create tags for Dept 1, Dept 2 and Dept 3. Users can select which they want. What you cannot do any more is have a single filter that say Dept 1 and Dept 2 but not Dept 3 OR Dept 1 and Dept 2. Each filter is based on a specific tag.

 

You can have filters for each of those three tags but not combinations.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

Peter,

Thank you for your patience!I'm totally new at this, and I'm elementary level, and trying to do College level work. So forgive me, but I'm missing somehting here.  I'm looking at your website and following along.  I've created 2 tags as above. I removed the 'group' in the dynamic content filter and just dragged and dropped the tags into the window.  The dynamic content filter is attached to the output preset. I generate the output preset, and I still only get 1 of the departments listed in the filter.  How do I get both departments in the list so the participants can choose between them?

 

Thanks again for all of your help!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

To clarify a bit more, the user can select combinations, it's just that you cannot create a single filter for a combination.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

I thought from something you said in the other thread you had used DCF (Dynamic Content Filtering) before. Apologies.

 

Your setup looks something like this?

 

image.png

 

There are some topics with either or both tags?

 

Please add screenshots of the above and the filter options that the user sees. It helps if you use the photo icon to insert images within the post. Seeing an image inline with the text makes it easier for anyone answering or viewing the post.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

Peter, Yes, this is the first time since training that I'm doing the filter. I've checked the 'compass travel' example but it was built in a previous version. So, following your website (the link you gave above) I did the following:

My filter looks like this:

 

cwilbur_0-1643653901116.png

 

I generate, and view, and this is what the participants see:

cwilbur_1-1643653967365.png

They only see Superior, not Superior and Davis.  I do not have either of these set as a default. And, I have topics with both Superior and Davis assigned to them.

 

Thanks for your help.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

Note the selected check box in my screenshot. Does that change it? 

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

No, it didn't change it. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2022 Jan 31, 2022

Copy link to clipboard

Copied

First try it in a new simple project. Sometimes that makes it easier to see the problem. If it doesn't, can you share the project? If you can, then see the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

I created a simple project with 1 folder and 3 topics. one topic with dept 1 filter, another topic with dept 2 filter and the other topic without a filter. I generated and previewed.  The filters worked -- both filters show on the preview.

 

But it still doesn't work in the large project. I can't send the project because of  proprietary information. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Add a new topic with just the tag that is not appearing. Does that change anything?

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

The same thing happens.

Is there something in the SKN? I duplicated the Studio and changed for my company. I didn't change anything in the SKIN for filters.  Do I need to?

 

Is there a container that holds the filter in the SKIN, and do I need to add filters to it? I'm pulling straws at this point, I really don't know???

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

one more caveat to add.  On the topic page, no filters display.  this is what I get when I click on fitler on the topic page:

 

cwilbur_0-1643741371486.png

nothing displays for filters.  

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Import a fresh version of the skin and give it a slightly different name. Does it work then?

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

Please let me know if it works with a new skin. If that doesn't make a difference I think the issue could be how your topics are tagged. The problem is my hands are tied. It's like reporting your car is broken down but not letting the mechanics see the engine. 🙂

 

If you will share it with Adobe, then try Support. See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your Adobe Support options. The email link tcssup@adobe.com is recommended as it reaches a team dedicated to Technical Communication Suite products including RoboHelp. 

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

I hear you. I'm working on building the new skin now. I'll let you know as soon as I test. fingers crossed!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

No don't make any changes to the skin at this point, just create a new one with no changes to rule out any of the changes being the problem.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

I added a new framelss Studio skin, didn't make any changes to the skin. I added to my output preset and hit generate. Message from RH is -- it failed to generate the Output preset. Ugh!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

OK, so now this quirky software isn't generting anything. Let me close out and open again, and try again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2022 Feb 02, 2022

Copy link to clipboard

Copied

ok, I got the project to generate with the plain Studio frameless skin. I'm getting the same results.

 

Ok, so it worked with the simple project (I'm applying the tags correctly), but it doesn't work with this more complex project.  

I cannot send you the full project even if I removed proprietary info because I can't send a file that big.

Can I email you screen shots?  What do you want to see? I could put them into a PPT.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp