Repeated cross-ref text in Word output

Explorer ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

I'm trying to get Cross-References to work in my Word output. They work fine in a PDF output, but in Word the selected text is repeated. This is happening for cross-referenced headings, paragraphs, and bookmarks alike.

 

For example, if I xref to a heading in a different topic called "Topic ABC," the link in the xhtml appears as See "Topic ABC" as expected. Ditto for PDF output. But in Word, it appears as See "Topic ABCTopic ABC", where the second instance is a link but the first instance is just extra. Note that this doesn't seem to be an issue for xrefs at a topic level, only xref to content within a topic.

 

Is anyone else seeing this? Is it a bug, or is there something I can do to fix the issue? (I've updated to the latest v7, but that didn't solve my issue.)

 

Thanks!

TOPICS
Output presets

Views

85

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 28, 2022 Jan 28, 2022

I have attached two PDFs of a topic I created showing various ways of linking.

 

The first time I ran the test I saw the problem as you will see in Word Output 1. I then tried various things to find a fix but they didn't work so I restored things to how they were. As you will see in Word Output 2 it now seems to work as it should.

 

I will report this to Adobe but meantime try deleting the cross ref that isn't working and then adding it in again. Does it then work?

______________________________

...

Likes

Translate

Translate
Adobe Community Professional ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

So that I am clear on the terminology, if you set up a hyperlink to another topic, that is fine in Word but a hyperlink to a bookmark within the same topic gives this problem.

 

In 2020 when you click the Link icon on the toolbar there are two options. Cross Reference and Hyperlink. Which are you using?

 

Please let me know that and I will something up tomorrow to test what I get.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Thank you! 

I'm inserting a Cross-Reference using this method: Insert Link > Cross-Reference > select a topic > Type: Heading/Paragraph/Bookmark > Format: Heading text with page number

 

In the Word output, I end up with both a Word Cross-Reference and a link, side-by-side, so it looks duplicated.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

I'm not suggesting it as the answer but for the links to bookmarks try using a hyperlink on just one. Let me know.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Yep, using hyperlinks did work, but it seemed like making extra work to add a bookmark to each heading I want to cross-reference when I can just cross-reference the existing headings themselves. Also, I didn't like the underscores in the hyperlinked bookmarks...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

OK. Let me check it out tomorrow. 

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

I have attached two PDFs of a topic I created showing various ways of linking.

 

The first time I ran the test I saw the problem as you will see in Word Output 1. I then tried various things to find a fix but they didn't work so I restored things to how they were. As you will see in Word Output 2 it now seems to work as it should.

 

I will report this to Adobe but meantime try deleting the cross ref that isn't working and then adding it in again. Does it then work?

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

Sorry, I'm not seeing it work in your second output. Looks like the problem persisted.

Deleting and re-adding didn't fix it for me. And thank you for reporting the issue to Adobe!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

See RH-10519 | Tracker (adobe.com)

What would help is you are still seeing this issue after checking you setup dialogs are the same as mine, is a couple of screenshots.

One of the Insert Cross Ref link dialog and one of the code in the topic.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

This is a screenshot of the Word document itself.

 

image.png

 

The issue is creeping back in when I generate that Word document to PDF. I have just generated Word again and it is correct in Word but not in PDF.

 

Please post a screenshot of the source code of the line with the link.

 

My next step would be to create a new two topic project and try there. Maybe that will reveal something. As an update has just been released, any fix from Adobe will likely be some time.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

LATEST

I have now attached the Word document so that you can see the expected result.

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp