RH 2020 doesn't save changes to Map ID

Participant ,
Feb 25, 2022 Feb 25, 2022

Copy link to clipboard

Copied

I found something strange with Robohelp and I am wondering if anyone else sees the same thing. Whenever I try to change the Map ID, Robohelp does not save my changes. Here are some detailed steps you can use to show the problem (but you may find you don't need them):

If you don't already have a map file:

1) In Output tab, click Map Files.

2) Click the "+" , select "New Map File", and type in a name.

3) Insert a topic by either drag-n-dropping it or clicking the "+" on the right.

4) Save the map file.

Once you have a map file:

5) In the MAP ID column, edit the Map ID of a topic following these steps:

a) Position curser at the end of the present map ID.

b) Type 5-6 characters to the end if the Map ID.  Note: type the characters rather quickly. Don't pause between typing each chararacter.

c) Save the map file, close it, then reopen it.

When I follow these steps, my changes made are not saved.

However, I found that if I wait about 1 second between typing each character, robohelp saves what I typed.

Another thing I noticed is the the "*" next to the map file name, which is suposed to indicate a change in the file, does not appear if I type fast, but does if I type slow.

I think I may have also seen this behavior with some other RH forms, but this is the first time I tried to reproduce the problem so I don't know for sure.

 

My current version is: 2020.7.46

TOPICS
New UI

Views

53

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 25, 2022 Feb 25, 2022

Copy link to clipboard

Copied

Is your project on a local drive or a network drive?

 

Has this worked OK before and just started?

 

Have you tried rebooting?

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 27, 2022 Feb 27, 2022

Copy link to clipboard

Copied

Whenever I make a change in an RH2020 field (anywhere in the interface), I tab a couple of times to move the cursor to a new field. Usually this ensure RH knows the current file has been modified. I don't know if this will help with map ids, but worth trying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

Answer to Peter's questions:

Q: Is your project on a local drive or a network drive?

A: local drive. It even happens with a brand new project. Just add one topic, then add a map file and add the topic to the map file. Then delete a few characters from the MAP ID.

 

Q: Has this worked OK before and just started?

A: I just started usin Map files for real, so I don't know.

 

Q: Have you tried rebooting?

A: Yes, this does not fix the problem.

 

I also tried Amebr's suggestion of using tab several times. While this works on other fields in RH, it does not help with the Map ID problem. 

 

In addition, I had a coworker try it and she has same problem. I was hoping to get someone in the forum community to try it before I create a bug report.

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2022 Feb 28, 2022

Copy link to clipboard

Copied

LATEST

Rather than create a bug report I would go to Support.

 

  1. I don't think it is a bug or others would be reporting it.
  2. A bug report will be looked at in time. Support should come back to you in a day or two.

 

See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your Adobe Support options. The email link tcssup@adobe.com is recommended as it reaches a team dedicated to Technical Communication Suite products including RoboHelp. 

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp