Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


RH2017 - Click here to see page in Full context option goes missing in IE browser

Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

Hi,

When I launch context-sensitive help topic in Chrome I get this Click here to see this page in full context option as expected in the top-right. It does not show up in IE.

 
 

Any idea how to fix this? Is this an IE issue? Any workaround?

 

 

TOPICS
HTML5 layout

Views

331

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Dec 12, 2019 Dec 12, 2019
Right, the master page was corrupt I guess. I created a new one and used the same css and header and footer.

Likes

Translate

Translate
Adobe Community Professional ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

It's not an IE issue and it does not need a fix. The issue is how you are calling the help. If you just put in the path you will get just the page, with the option to open the full help. If you want to have CSH with the full page, see Calling Help on my site.


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

I just generated a responsive output from 2017 and a direct call works fine locally in IE. Does it work locally for you and just not on the server? If it doesn't work locally, I don't know what the problem is given it works here.

 

Is 2017 up to date?


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

We are good with just the page, with the option to open the full help. However, the option to optin the full help shows up only in Chrome and not in IE. Why would it not show in IE?

option.JPG

Option2.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

Ok, let me check and get back.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

Did you enable JavaScript in IE for the site?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

Ah! I havent checked this. Let me try.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

Yes, tried by enabling Javascript in IE settings but no luck. In fact, Javascript was already enabled.

Any other thoughts? Strange that this happens only in IE and Chome gives no issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 05, 2019 Dec 05, 2019

Copy link to clipboard

Copied

Do you think the developers will have to fix this in their help call code? given that it works as expected on Chrome and not on IE? Just trying to figure out if IE ot Rh has any setting that can handle this before approaching the development team to update the code.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

To the best of my knowledge there are only two settings in IE that affect how help works. I disabled both of those and the link still worked.

 

When I said the issue is with how you are calling the help I was under the misaprehension that you didn't want the help to open with just the topic and the link, rather than wanting it to open that way but with the link.

 

I'm sorry but I don't know why the link is not working for you. Have you tried another project?

 

This link opens a topic on my RoboHelp Tour with the Click here... link to the full help. Try it in IE yourself to see what you get.

 

http://www.grainge.org/pages/authoring/rh_tour/rh2019/rh2019.htm


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

ONe more observation.

I generated a fresh output and from the output folder (before embedding in the product) directly opened the context sensitive page on Chrome from my local machine like right click and open with chrome. It shows the Click here... link.

I did the same right click and open with IE. The Click here... link is still hidden. The header in fact goes missing in IE

This is before the help output is in the product even before the context sensitive help calls are made. On my local machine.

Any pointers? 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

Yes, what I suggested before. Try another project or the link I provided. That will tell you whether the issue is your project or IE.

 

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

Your link works as expected for me on IE. I think the issue is with my project in that case. That is why the header disappears in IE and shows up only in Chrome.

Is there some setting related to that in the help tpic or somewhere else that I am missing perhaps?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

The only setting is whether or not you get the link at all. It is not browser specific.

 

I doubt it will help in this case but have you tried deleting the CPD file and restarting RoboHelp?

 

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

Hmm deleting CPD and restarting Rh didn't work. I shall also check on the most latest version of IE. I have 11.0.150 on the server. The latest is 11.0.160. will try that as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 08, 2019 Dec 08, 2019

Copy link to clipboard

Copied

ONe more obeservation sorry. I tried additionally on Mozilla Firefox as well and it works as expetc just like Chrome.

On IE the popup page also has the maximize icon disabled and the scroll disabled as well.

On Firefox and Chrome maximize and scroll works.

Before I have the developers relook at the code just want to make sure it is not IE related issue. 

Also tried IE v 11.0.150 and IE v 11.0.160.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 08, 2019 Dec 08, 2019

Copy link to clipboard

Copied

As I have said, I don't believe it is your developers' call. If that was wrong, it would not call the help in any browser.

 

You have ruled out it being IE by using the link I provided to my site. That worked correctly.

 

That leaves one place, your project. Create a new project with just a couple of topics and try that. If that works, hopefully comparing the code will give a clue.


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 08, 2019 Dec 08, 2019

Copy link to clipboard

Copied

So looks like I could catch the source of the issue.

In the same project I created a test topic, and did not apply the master page to it.

I saved the topic and pulled it in the Toc and then generated the responsive html5 output.

It works in IE as well as Chrome as expected.

As soon as I apply the master page to it and regenerate the output and try, it stops working in IE but works only in Chrome and Firefox. The master page seems to be the root cause and/or the underlying CSS that the master page uses.

What is in the master page that may be blocking this part from displaying? Any pointers?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2019 Dec 09, 2019

Copy link to clipboard

Copied

Create a new master page without making any edits and do not apply a CSS? Link it to a topic instead of the existing master page.

 

What happens with this master page?

 

If that works OK, attach your CSS to it and try again.

 

If it doesn't keep amending the new master page bit by bit to be the same as your existing CSS.


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 09, 2019 Dec 09, 2019

Copy link to clipboard

Copied

Ok. Will try. Just wondering if it is an issue with the CSS.

Can I create a new master page with the same name? I will rename the existing one to _old or something like that. And then add the info to it one by one to see where it breaks.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 12, 2019 Dec 12, 2019

Copy link to clipboard

Copied

The above steps suggested by Peter are correct. I tried the above steps in the same sequence and it worked. Helped figure out the issue in the master page.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2019 Dec 09, 2019

Copy link to clipboard

Copied

I think you can rule out the CSS in your topics as it works OK with no master page applied. The rest will tease out where the issue is.


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2019 Dec 09, 2019

Copy link to clipboard

Copied

I would give it a different name and work with one topic until you know what the problem is. Then maybe using renaming.


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 10, 2019 Dec 10, 2019

Copy link to clipboard

Copied

Finally, found the root cause. Whew!!

When I disabled breadcrumbs in the masterpage and viewed the responsive html5 output in IE, it works as expected. So enabling breadcrumbs in the masterpage is the issue.

Perhaps breadcrumbs in RH 2017 seem not to go well with IE latest version.

Chrome and Firefox, no issues. It works.

If anyone has a workaround for breadcrumbs to work on IE do share.

For now I am disabling them and defining browse sequence so the users have something to navigate.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 10, 2019 Dec 10, 2019

Copy link to clipboard

Copied

I added a master page with breadcrumbs and it is still giving the link. Have you tested that in another project?


www.grainge.org

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2
Resources
RoboHelp Documentation