Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


[RH2019] %2F in URL without #t= causes hyperlink issues

Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Three examples, A & B are fine but C is broken.

 

A: If a page is shown in context, it includes a %2F slash in the URL and it works fine:

localhost/index.htm#t=The_Asset_Editors%2FSprites.htm

B: If a page is shown without context, it includes an actual slash / and it works fine:

localhost/The_Asset_Editors/Sprites.htm

C: However, when an out-of-context page includes a %2F slash, it works BUT causes an issue:

localhost/The_Asset_Editors%2FSprites.htm

What issue does this cause?

In this case, it does not seem to know that the current page is inside the "/The_Asset_Editors/" directory. So if there is a hyperlink that takes you to "Objects.htm", instead of taking you to "/The_Asset_Editors/Objects.htm" it takes you to "/Objects.htm" which doesn't exist.

Also,

I am not sure how a user is reaching example C organically.

Thank you

Views

262

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Are you using RH2019 Classic or New UI? Do you have all the patches installed (last one was 14)? Which output are you generating? Is context sensitive help involved?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Hi! I'm using the new UI, patch 14 is installed, and the output is Responsive HTML5. Context sensitive help is involved but it is not clear how the broken URL is reached.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I'm unclear on your terminology - what do you mean by "in context", "without context" and "out-of-context"?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Context as in the ToC visible on the left side, because when the page is being viewed on its own it says "View page in full context" and then you see the ToC.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

Because context sensitive help is in play I'd be looking at how the help is called from the application. That seems the most likely place for the path to be escaped like you describe. You'll need to speak to your developers to help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I've tried and the application seems to open the correct / slash URL.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 11, 2021 May 11, 2021

Copy link to clipboard

Copied

I am not a specialist here, but I have had an issue with thumbnails that could not be found due to a corrupt path. This has been fixed in version 2020 update 4. 

In my case, the problem only occured when the help was embedded within an iFrame. 

For reference, you could see this original post: https://community.adobe.com/t5/robohelp/rh2019-new-ui-problem-with-thumbnails-in-html5-help/m-p/1160...

 

Maybe this helps you or your developer to find out what is causing the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

AFAIK there's only 2 ways to launch your content - (1) invoke the index.htm page - this would be the full help (with TOC visible) and you'd end up on a default topic as the landing page; (2) invoke the specific topic within the content (this is traditionally called CSH (Context Sensitive Help) because you "know" the context of where you are in the launching application and only want content about that screen presented). This CSH launch traditionally doesn't present the TOC (but offers a link to expose it and show it in its position within the TOC). Some versions of RH have monkeyed with this content-only view because of the impact on Google searches, but I believe that has been fixed now.

I have no idea how you are launching what you call an "out-of-context" page - perhaps you can describe that scenario?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

LATEST

I am also not sure how the user who reported the bug reached that page. I am trying to contact them to get the steps to reproduce it, but right now I cannot reach that link organically at all, even through the app's context sensitive help feature.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation