• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

RH2020 Generating Blank PDF

Community Beginner ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I upgraded a previous 2019 project to the most recent version of 2020.  In 2019 I was able to generate a PDF. In 2020 it will only generate a single page, blank PDF file.  I am able to successfully generate a PDF using the Compass Travel sample project.  Something has to be wrong in my project to generate a blank PDF, I just can't figure out what is wrong. Any ideas? I read through Peter Grainge's post about PDF output and the TOC. I don't see what could be causing the problem.

Views

414

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Jun 21, 2021 Jun 21, 2021

Hi,

 

Andrea shared her project with us and issue was incorrect comment syntax inside <style> tag in head of html topics.

After fixing those errors in topics, Andrea is able to generate PDF fine.

Please share your project also with us and we will be glad to help you.

 

Thanks and Regards,
Surbhi Maheshwari 

Likes

Translate

Translate
New Here , Jun 21, 2021 Jun 21, 2021

Thanks Surbhi,

She helped me use RH find and replace to change my <style> tag from:

<style type="text/css">
/*<![CDATA[*/
< !-- div.WebHelpPopupMenu {
position: absolute;
left: 0px;
top: 0px;
z-index: 4;
visibility: hidden;
}
p.WebHelpNavBar {
text-align: right;
}
-->
/*]]>*/
</style>

 

to

<style type="text/css">
/*<![CDATA[*/
div.WebHelpPopupMenu {
position: absolute;
left: 0px;
top: 0px;
z-index: 4;
visibility: hidden;
}
p.WebHelpNavBar {
text-align: right;
}
/*]]>*/
</style>

 

Just by replacing the <!-- and --> with blank spa

...

Likes

Translate

Translate
Community Expert ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Did you try creating an entirely new Preset for PDF? (not copied, new named)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I did.  I added a new PDF preset with a new name and generated. Again a single blank page PDF.  I assume it's something wrong with my TOC but I can't figure out what!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I'm experiencing the same one single "blank page" issue when generating a PDF from Robohelp 2020.5.71. My project was also 2019, then upgraded to 2020 in April. Earlier today, I tried generating a PDF and received "failed to create PDF messages."  I upgraded to 2020.5.71 and realized I need JRE for PDF generation, so I installed it.  Now, instead of no PDF file being generated, I get one single blank page.  I can generate a PDF from the "About Robohelp" sample project file. So, I copied the .css and MasterPage info from that project into my current one, making sure all ToC and PDF output settings match the sample and still no luck.  One blank PDF page is my output. Is anyone else seeing this? I've been messing with RH2020 for over 3.5 hours today.  I also created a new preset for PDF but that didn't help either.  

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I think you are going to have to contact the RH folks about this one - see https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your support contact options.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Hi,

 

Can you please share the 2019 project with us at sumahesh@adobe.com

Please mention the TOC you are using to generate. We will try it at our end and let you know.

Your help is highly appreciated.

 

Thanks and Regards,
Surbhi Maheshwari

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Hi,

 

Andrea shared her project with us and issue was incorrect comment syntax inside <style> tag in head of html topics.

After fixing those errors in topics, Andrea is able to generate PDF fine.

Please share your project also with us and we will be glad to help you.

 

Thanks and Regards,
Surbhi Maheshwari 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Thank you so much for taking the time to help us figure this out!  Andrea and I work closely together so she has shared your findings with me.  I know what I need to remove from the html to get the problem solved.  If either of us have any further issues we will let you know. Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Glad to know that it's resolved for both of you. Kindly mark my earrlier comment as correct response so that this thread is closed.

Feel free to reach out to us in case you face any challenge while using RoboHelp.

Regards,
Surbhi Maheshwari

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

Hi Surhi,

I've sent you an email for the same support if you will, thanks!

Regards,

Dave.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Thanks Surbhi,

She helped me use RH find and replace to change my <style> tag from:

<style type="text/css">
/*<![CDATA[*/
< !-- div.WebHelpPopupMenu {
position: absolute;
left: 0px;
top: 0px;
z-index: 4;
visibility: hidden;
}
p.WebHelpNavBar {
text-align: right;
}
-->
/*]]>*/
</style>

 

to

<style type="text/css">
/*<![CDATA[*/
div.WebHelpPopupMenu {
position: absolute;
left: 0px;
top: 0px;
z-index: 4;
visibility: hidden;
}
p.WebHelpNavBar {
text-align: right;
}
/*]]>*/
</style>

 

Just by replacing the <!-- and --> with blank spaces within the code view search in my <style> tag, generating a PDF works great now!  I will see if I can further cleanup my stylesheet if I'm not using the "div.WebHelpPopupMenu {" or the "p.WebHelpNavBar{" info.

 

THANKS Surbhi!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

Hello all,

 

I'm having the exact same issue, except for the Word export instead of PDF. I'm not seeing the same <style> syntax issue referenced above in the topic I'm trying to export. Any thoughts?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

Hi @Cameron5C0F I'm assuming you created a book style TOC and used that when generating your Word document?  Something that helped me was deleting the output preset and creating a new one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

That's correct. I've tried making a new output, a new book TOC, and both
and still run into the same issue. I initially thought the mini-TOC and
bookmarks within the topic might have something to do with it but removing
those had no impact either.

--
This email and any files transmitted with it are confidential and intended
solely for the use of the individual or company to whom they are addressed.
Do not disclose, distribute, or copy this email to others outside your
company. If you have received this email in error, please notify the sender
immediately and delete this email from your system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 14, 2022 Sep 14, 2022

Copy link to clipboard

Copied

I'm grateful for this thread! I am getting the same blank page when I try to generate PDF output. I don't know enough about HTML to manipulate the source code. Is there any more detailed documentation that I could refer to so that I can fix this in my project? Thanks! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 14, 2022 Sep 14, 2022

Copy link to clipboard

Copied

I assume you are getting stuck on the first suggestion. What you need to do is look in the source code at the top of the topic for the following text and delete only the marked symbols (<!-- and  -->)  :

<style type="text/css">
/*<![CDATA[*/
< !-- div.WebHelpPopupMenu {
position: absolute;
left: 0px;
top: 0px;
z-index: 4;
visibility: hidden;
}
p.WebHelpNavBar {
text-align: right;
}
-->
/*]]>*/
</style>

 

OR

 

<style type="text/css">
/*<![CDATA[*/
< !-- div.WebHelpPopupMenu {
position: absolute;
left: 0px;
top: 0px;
z-index: 4;
visibility: hidden;
}
-->
/*]]>*/
</style>

 

 

Does that help?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 15, 2022 Sep 15, 2022

Copy link to clipboard

Copied

I will give this a try-- thank you-- do I do this for every topic? I have hundreds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 15, 2022 Sep 15, 2022

Copy link to clipboard

Copied

I have not found those symbols in any of my source code. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 15, 2022 Sep 15, 2022

Copy link to clipboard

Copied

Can you generate a pdf successfully using one of the sample templates? They should be in your Documents/My Robohelp Projects folder. If not, you can copy them from the adobe robohelp installation folder under Program Files. Don't try to run them from the installation folder though as they won't work because of Microsoft Security features on that folder.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

Yes! Compass Travel PDF generated smoothly. 

Is there a particular topic where I should look for the code to alter? I tried looking at the html for the CSS, but I don't know where to look for the html that incldues the style tag.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 19, 2022 Sep 19, 2022

Copy link to clipboard

Copied

LATEST

Okay, that proved that there isn't a problem with your installation. Now let's check if there is a problem with your css file. The quickest way to test is to open the css folder in File Explorer and rename the css files (append '.old' to the end of the file name for example). Don't rename in Robohelp as that will update all the references which we don't want right now.  To quickly open the correct folder, right-click on the css file in Robohelp and select 'Show in Explorer'.

 

Renaming the file this way will break all the links. Everything will look wrong but don't worry about that for now. If the project now generates it means there's something wrong with your stylesheet. If it doesn't then there is something wrong in one or more topics.

 

Once you've tested whether it generates correctly you can undo the changes to the css file names to put your project back the way it was, ready for the next step.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp