• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

RH2020 - Mini TOC ignores Conditional Tags on Headings

Explorer ,
Dec 01, 2021 Dec 01, 2021

Copy link to clipboard

Copied

In my RH2020 project I use conditional tags to control output for different audiences. In one case I have a sub-heading that needs to be different according to user. The conditional tags work fine in the body of the topic; however the Mini TOC is completely ignoring the tags and displays both headings as links.

 

This was not a problem in our previous version of RoboHelp (RH9). The output from RH9 only shows the proper heading in the Mini TOC. I have tried removing all conditions and replacing but that didn't help. Have also tried putting the two headings on separate lines but that just displays the two links on separate lines in the Mini TOC. 

Views

61

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 01, 2021 Dec 01, 2021

Copy link to clipboard

Copied

I can replicate in RH2019 so I think this counts as a bug. 

Amebr_0-1638401962178.png

 

You can request features and report issues here: https://tracker.adobe.com/

Post the item number in the discussion so people can easily vote if they want the same functionality.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 02, 2021 Dec 02, 2021

Copy link to clipboard

Copied

LATEST

Thank you for your responde, Amebr. I have also noticed another issue with Mini TOC as the caption is not changing when clicked to collapse it. When expanded, the default caption is "In this Topic Hide" and when clicked to collapse it should change to "In this Topic Show" but it remains as "Hide" which is confusing since it is already hidden.

 

I have reported both issues as a bug and the item number assigned is RH-10402.

 

Thanks again for the confirmation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp