• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Robohelp 2020 and SharePoint

New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

We are fairly new to using robohelp and are unable to create the connection profile in robohelp to publish to SharePoint Online.   When creating the profile, I am prompted to log into Microsoft.  When I log in, I receive a SharePoint site error that says "Could not find site. Check if you have permission for this site."

 

Our IT team has whitelisted the necessary sites and granted us what we think are the right permissions.   I have a feeling we need Admin level Microsoft permissions to grant Robohelp rights to publish to our SharePoint Intranet page.  

 

We can upload the project files and folders to the site to publish, but we have merged projects so  uploading does not seem to be an option for us.

 

Any ideas or suggestions would be very helpful.   Thank you very much.

Views

343

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

First make sure you're all patched up with the latest Patch version (#7 as of March 2022) - then search the forum for posts about connecting SP and RH - there's been a bunch out there. If you still have no joy, contact the RH folks - see https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your Adobe Support options. I'd recommend using the tcssup@adobe.com e-mail address as it reaches a team dedicated to Technical Communication Suite products including RoboHelp.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2022 Mar 15, 2022

Copy link to clipboard

Copied

Good morning,

We did try to create the connection after installing the updates.   We still get the same error message:  "Could not find site. Check if you have permission for this site."

 

We will conact Adobe support.

Thanks for the suggestion.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 15, 2022 Mar 15, 2022

Copy link to clipboard

Copied

Please post the solution when you have it to help the next person with this problem.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2022 Mar 15, 2022

Copy link to clipboard

Copied

Thank you Peter,

I will definitely do that.  In the meantime, if anyone reading this post has had this problem and identified a solution, I would really like to hear it.  We've been troubleshooting all possibilities for a while now.   

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Mar 19, 2022 Mar 19, 2022

Copy link to clipboard

Copied

I have been helping Amy offline and working with Adobe engineering to solve this problem. Amy has valiantly run through all the suggestions, but no joy. Adobe  supports suspicion is that there is a firewall issue between Amy's (and her colleagues') desktop and the Sharepoint Server. Her Admins have done their best to whitelist URLs as directed here:

https://helpx.adobe.com/robohelp/using/sharepoint.html

If someone has encountered this issue and found a missing link in the firewall workflow, we'd appreciate hearing from you.

Thanks

John Daigle
Adobe Certified RoboHelp and Captivate Instructor
Newport, Oregon

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 06, 2022 Dec 06, 2022

Copy link to clipboard

Copied

Running into the same problem and have searched the forum for solutions. Were you ever able to figure this out?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2023 Apr 27, 2023

Copy link to clipboard

Copied

Experiencing the same issue with RH 2022... 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 28, 2023 Apr 28, 2023

Copy link to clipboard

Copied

This post - https://community.adobe.com/t5/robohelp-discussions/robohelp-2019-and-sharepoint-online-connection-f... - talks about tweaks needed to be made on the SP server.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 09, 2023 May 09, 2023

Copy link to clipboard

Copied

If we disable Netskope, we are able to download the project but as soon as we enable it we cannot, the project is empty. 

Do you know to which url to  update that certificate?

$ export NODE_EXTRA_CA_CERTS=[your CA certificate file path]

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 09, 2023 May 09, 2023

Copy link to clipboard

Copied

This thread - https://community.adobe.com/t5/robohelp-discussions/robohelp-and-netskope/m-p/13780400#M149676 - talks about changing a Windows environment variable to add that path to the certificate file. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 10, 2023 May 10, 2023

Copy link to clipboard

Copied

LATEST

We fixed the issue by including robohelp.exe in netskope exception list. FYI we are in a virtual environment 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp