• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Robohelp 2020 buggy conditional text

Participant ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Hi all, 

I have just started using RH2020, having moved from 2019 Classic version, so the whole interface is new to me. I have downloaded the latest updates. I am at the point of giving up and re-installing 2019 as I just cannot get it to work properly. To me, it seems to be very buggy and just does not seem to be working as expected, but am hoping it is me, rather than the software. Some issues I'm having:

  • If I apply bold to a word, then try to toggle it off again, sometimes it does not work.
  • Sometimes I apply a condition to a word or sentence, then right-click to remove it, and the option is not there.
  • Sometimes I apply a condition to a word or sentence, yet under Content Properties it does not show  that conditional text has been applied. Sometimes it does.
  • I have a bulleted list of 5 items where items 2 and 5 are conditional. When I generate, I still get the bullets on the lines that are conditional. I've tried selecting the carriage returns (view >Show>Paragraph Markers), as I know that this is what caused the same issue in Framemaker  but I get carriage returns that I cannot select (I have read an article in this community which advised to just ignore them, so I have). And even if I do manage to select and conditionalise the carriage returns, the same thing happens. I resorted to removing the carriage return altogether and merging the text with the previous line, which did work but it's only a workaround.

It just seems terribly buggy and inconsisten to me but no one else seems to have complained of this so am wondering if it's my system in some way. If I can't get these fixed I'll have to go back to the 2019 Classic.

 

Hoping someone can help.

Thanks

Laura

 

Views

94

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

As you say, it is not a general problem. You say you are on the latest version so please confirm the help menu shows 2020.4.

 

I have answered the points below but also try these issues in the supplied About RoboHelp project that you will find in Documents > My RoboHelp Projects

 

If I apply bold to a word, then try to toggle it off again, sometimes it does not work.

I have been using CTRL B and it works without issue. Is that how you are doing it?

 

Sometimes I apply a condition to a word or sentence, then right-click to remove it, and the option is not there.

What is not there, Remove Condition Tags? I'm guessing Apply is still there and selecting that also allows you to remove the tags.

 

Sometimes I apply a condition to a word or sentence, yet under Content Properties it does not show  that conditional text has been applied. Sometimes it does.

 

I have a bulleted list of 5 items where items 2 and 5 are conditional etc

You should see the condition colour across the whole line rather than just the text.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Thanks for that Peter. The problem here is the inconsistency of when the problems appear. Sometimes things work as expected, then 10 minutes later, or in a different topic, I try the same thing - nothing happens.

I think it may be this particular project (I hope) that is having problems. I have tried with another, smaller project and it seemed fine on first try.

I will post if I discover more over the next days. Thanks for your help

 

Laura

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Let's try this: Next time the conditional text issue appears, switch to the source code view, copy the paragraph (list item) where the effect happens, and paste it here. Maybe there is some code construction/complexity that is causing this issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

LATEST

If you're importing or pasting content from Word documents, you'll get a lot of HTML tags you can't necessarily see in RH. This can prevent options showing up that you expect (because you're not in the HTML tag you need to be).

 

I recommend using the hierarchy breadcrumbs at the top of each topic tab. They show you the hierarchy of tags your cursor is currently inside. In this example, my cursor is inside an em tag, which is inside a strong tag, which is inside a list item (li) tag, which is inside an unordered (bullet) list tag, etc, back to the body tag.

Amebr_0-1619618877116.png

 

When you want to apply a condition to a list item, I would recommend clicking on the li in the breadcrumbs, which will correctly select the entire list item, then apply the condition tag.

 

When you drag the mouse to select, you are likely selecting only the content of the list item, not the li itself. That would explain the bullet still appearing but not the content.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp