• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

RoboHelp 2022: unable to publish webhelp

New Here ,
Jun 25, 2024 Jun 25, 2024

Copy link to clipboard

Copied

I have upgraded a RoboHelp 2017 project to RoboHelp 2022. I'm trying to get a webhelp output from the 2022 version. I have generated the required presets etc. Publishing the webhelp gets stuck on rhlog.txt file:

anul5157325_1-1719317992043.png

I tried pubilishing with the Republish All option so it wouldn't write the rhlog but get an invalid destination path error:

anul5157325_2-1719318104880.png

I've set Server Type to File System as the help project is local (on my Windows laptop) and not on any external server.  

Any ideas what might be the issue or what I'm doing wrong?

Thanks in advance!

Views

112

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

Just a note that webhelp no longer exists in RH2019 New UI and newer. Your webhelp will have been converted to HTML5 output. The name of the output preset won't have been changed as it's just a text string that could be anything, but the actual output type has been. (You can tell by the icon which is a shield with a 5 in the centre). 

 

Regarding the error message, it's saying the destination path has something wrong with it. Check the path doesn't have any weird characters, and the location actually exists. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

I've checked the path multiple times and tried copying the project to a different location and updated the paths accordingly but still get the same error with Republish All. And without Republish All, it gets stuck on the rhlog.txt file. Generate Preset replaces all the previous contents in the destination folder.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

If you only need the output locally, why are you publishing? All publishing does is copy the folder to which you generated to another folder using the various publish options.

 

The only reason would be because generating trashes the content of the target folder whereas publishing does not. If you have additional files that you don't want to be deleted, then you would publish but not otherwise.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

I need to get out a context-sensitive webhelp that is integrated into the product's UI. I have two output versions based on conditional tags going in two different destination folders. When I change the output folder and  select the appropriate conditional tags, the new RoboHelp asks to save a preset. The preset then replaces all the contents in the desctination folder and it's missing all the java script etc files that are necessary. The only options I have is Generate Preset, View Output and Publish and the first one does not create the output I need.

With Publish, I managed to get out the full output once but it didn't apply the conditional content without setting the preset, and now the Publish option keeps getting stuck.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

LATEST

Okay, you need to read Peter's Upgrading from Classic page as there are fundamental changes to the way things are done.

https://www.grainge.org/RoboHelp_Tour/rh2022/introduction/upgrading.htm

 

Most importantly, everything you want in the output must be be in the toc (i.e. baggage files) and marked as hidden in the toc. So that will most likely be why files you used to have the in the output are now missing.

 

Secondly, depending on how CSH has been done, your developers will most likely need to update the application as the URLs are differnt from webhelp

https://www.grainge.org/RoboHelp_Tour/rh2022/outputs/calling_csh_help.htm

 

Finally, I'm not sure what workflow you are using - it sounds like you are not using the Generate option. You absolutely have to, as this is what creates the output with your changes in it.Publish will only copy your old output without any new or updated content.

 

Anyway, read those two toics and come back with more questions once you've had a chance to understand the changes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp