• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Robohelp Server not displaying results

Explorer ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

I am currently testing the Robohelp server as we want to use it for insights within our organisation.

I published one of the projects on the server (which has 2 children). I then tested it to compare it with the one from our internal server. When using the same search in the search bar, Robohelp server was not as accurate as ours and it kept bringing up a specific document first no matter what the search was. A week later, no content from one of the children appeared anymore, no matter how I searched for it. Today I tested again and no content appears at all, that means the other child doesn't display any results anymore. The only result that appears is that odd document which kept appearing initially when I tested the server.

I tested this for another project with one child as the project is WIP and it's also not displaying any results.

Just to clarify the process I am taking:

1. Generate Child 1 locally

2. Generate Child 2 locally

3. Generate Master Project locally

4. Publish on Robohelp Server.

Another point to mention is that the drill down option works fine for both children so the content is there.

Am I doing something wrong? Do i need to publish or generate in a specific format or location?

Views

56

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Please use the photo icon to insert images within the post. Seeing an image inline with the text makes it easier for anyone answering or viewing the post.

 

Publishing to RoboHelp Server can be done in two ways to the best of my knowledge. Either the same way as on an ordinary server or I believe there is another way that I am not familiar with.

 

Using the same method as on an ordinary server, it is important that the parent is generated first as the child projects need to be generated to a specific folder that is created in the parent project output. See Merged Help (grainge.org) on my site.

 

If that doesn't help, then I think you may need to liaise with Support. See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your Adobe Support options. The email link tcssup@adobe.com is recommended as it reaches a team dedicated to Technical Communication Suite products including RoboHelp. 

 

You haven't mentioned your version of RoboHelp or RoboHelp Server. Be aware that there are compatibility issues between the two. Again, Support can help you on that.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Thanks @Peter Grainge . I will get in touch with support as the children are linked as per your guidance so not sure why the search doesn't work on Robohelp Server.

I have the latest version of Robohelp 2020.6.76. I am not sure how to find out the Robohelp Server version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

LATEST

I forget to mention there is a known issue with merged help not on RoboHelp Server. It is broken on an ordinary server. I would expect it to be broken on RoboHelp Server as well but I don't know for sure.

 

It will be fixed in Update 7. 

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp