• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Search stopped working

Explorer ,
Jun 08, 2023 Jun 08, 2023

Copy link to clipboard

Copied

Robohelp 2022.8.34

 

I just compiled my help system, and the search isn't working. I know I didn't change anything in the Frameless output preset or the Skin. It was working before, but now it's not.

 

When I type in the search box, autocomple works, but no search results are displayed.

 

Any thoughts?

 

JoeMajiq_0-1686266188440.png

 

JoeMajiq_1-1686266330211.png

 

JoeMajiq_2-1686266706652.png

 

Views

358

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jun 16, 2023 Jun 16, 2023

So, I don't know what happened, but we finally deleted the project from my PC and re-synched with the VSTS server.

 

I can't explain why that worked, but ok. Thanks everyone for the help! I very much appreciate your efforts!

-Joe

Votes

Translate

Translate
Community Expert ,
Jun 08, 2023 Jun 08, 2023

Copy link to clipboard

Copied

Is this after you copy the help to a web server or when you click the View Output option in Robohelp? If it's only from the server it could be a caching issue, as the search results are help in javascript files, which are typically considered "static" (that is do no change very often) files and are thus cached for long periods.

 

You could try clearing your browser cache, closing all browser windows and waiting for a couple of minutes then reopening the website to see if this fixes it. If so, a longer term solution for your users would be to get the server admin to set the max-age server header to a short time period (7 days for example, or 0 to turn off caching) for the folder these search/toc/index script files are in.

 

If it happens for the local copy as well, the only thing I can think of is if you updated Robohelp since the last time you generated, and maybe something broke? But I'd have expected more reports of this problem if that were the case.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 09, 2023 Jun 09, 2023

Copy link to clipboard

Copied

Thanks for the response. The search doesn't work both locally, nor from the server. I cleared my browser cache, and the problem persists.

 

I'm running the 2022.08.34 version, and I've been on that through many deployments. The only things I've changed are adding and editing topics. I haven't messed with any settings since I got the help system working last year.

 

Anything else you can think of?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 09, 2023 Jun 09, 2023

Copy link to clipboard

Copied

Given the search doesn't work locally, that suggests the problem doesn't lie with RH. Maybe it's a change to your antivirus or other corporate security tools, preventing the help from generating correctly ?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 09, 2023 Jun 09, 2023

Copy link to clipboard

Copied

Does it work with the sample projects?

 

RoboHelp creates two copies of the samples on installation. 

  • The copy to use is put in My RoboHelp Projects in the Documents folder that Windows creates in your profile.
  • Another copy goes into Program Files and should never be run from there as Windows will block some of the functionality.  The idea of the copy in Program Files is that it is a clean back up if you need to replace the copy in Documents.

 

Also I think someone posted a similar issue in the last few weeks. Search for that.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

There appears to be a JavaScript issue.

 

JoeMajiq_0-1686587075000.png

 

Local IT recently switched AV to Crowdstrike, but the server hosting the help files is still on Symantec. The local IT guy says he checked the logs and isn't seeing any flags from the AV software, but it would be a heck of a coincidence if the help stopped working after switching AV.

 

Any thoughts on what else could be the issue? Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

All the more reason to test one of the samples to see if they suffer the same problem.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

I compiled the Compass Travel example, and it works. But I would expect that as the local copy of my help system works also. But when I when open and compile from VSTS, my project doesn't work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

Can you not upload that for a quick test? 

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

I'm a little confused as before you said the local output didn't work, but now you say it does? I think I'm missing something here.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 13, 2023 Jun 13, 2023

Copy link to clipboard

Copied

My appologies. I got a bit discombobulated going in a dozen different directions yesterday. I just compiled another local copy of the help and the search didn't work.

 

One of our developers says he was able to get the search to work by "tearing down the mapping and doing that all over again". I'm not sure exactly what he means, but we're going to meet soon and do that on my machine. I'll let you all know how it goes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

"Robohelp 2022.8.34" - isn't that supposed to be 2020.8.34? RH2022 is only at Patch 2 right now (June 2023)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 12, 2023 Jun 12, 2023

Copy link to clipboard

Copied

Sorry, yes, 2020.8.34. But I've installed 2022.2.22, and compiled the help with that, and still have the same issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 13, 2023 Jun 13, 2023

Copy link to clipboard

Copied

It's easy to get lost when you're juggling 57 changes in an attempt to get things to work. 🙂

 

Do post back with what your dev does. (the words you passed on worry me, I admit 😛 )

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 16, 2023 Jun 16, 2023

Copy link to clipboard

Copied

LATEST

So, I don't know what happened, but we finally deleted the project from my PC and re-synched with the VSTS server.

 

I can't explain why that worked, but ok. Thanks everyone for the help! I very much appreciate your efforts!

-Joe

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp