• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Sharepoint online

New Here ,
Sep 12, 2019 Sep 12, 2019

Copy link to clipboard

Copied

How do i view the .aspx after uploading Sharepoint generated output from Robohelp 2019 (update 9) to Document Library on sharepoint online site?  The project generates the output just fine (creating aspx files).  I then manually upload to Document Library.  But when i click on the index.aspx, the browser downloads and prompts to open, versus running the aspx inline within the site.  I'm fairly new to Sharepoint so i'm sure i'm missing a step.  Any help much appreciated!

Views

544

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 23, 2020 Jun 23, 2020

Copy link to clipboard

Copied

Any chance you've resolved this? As I understand it, ASPX files must go into "Site Pages" to be able to be viewed in browser. What I don't know is what steps need to happen in order to get the necessary files from the Document Library to Site Pages; or better yet, is there a way to just get RH to upload everything to the right spot in the first place. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

I only see Documents or Pages. How do you publish? We have not been able to successfully update any published help file on SharePoint Online. Some of the files do not get published.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Have any of you had any luck? We've been struggling with similr challenges for weeks when manually uploadig "batches" to SP Online. Sadly ran out of options. Here are a few things that might help you with the puzzle though:

  • Make sure you SP Online site is added as a Trusted Site. If this is controlled by your admin, you should be able to see your current list of trusted sites in RegEdit
  • Enable "Custom Scripting" on your SP site. This supposedly allows ASPX files to execute, although that didn't make much of a difference. 

 

After doing the items above, we have been trying to copy the batch from a document library (or locally from the PC) into a folder under the "Pages" library. Sadly, any attempt to paste .aspx files there via Windows Explorer fails. Either a message comes up that the files can't be read or that the site has to be added to Trusted Sites. And as you may know, SP front-end doesn't give us the option to move files or folders into the Pages library from other libraries. 

 

We went the route of trying to upload batches manually since our "Connection Profile" feature isn't working. We're behind way too many firewalls and no matter what traffic we whitelist, we can't get it to work. Adobe ran out of options too. 

 

Thank you and good luck everyone! Please share if you've made any progress. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

I've been having success (mis-)using Microsoft's "Sharepoint Migration Tool" to upload the ASPX files generated by Robohelp into a folder created in my SharePoint sites "Site Pages". 

 

Once that's done, I just browse to <site>/SitePages/<project folder>/index.aspx and everything seems to work.

 

I'm sure this will all come back to bite me and/or seize to work at some point, but for now, it does the job. 

 

The SP Migration Tool, so far, is the only way I've found to be able to upload to Site Pages.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 20, 2020 Sep 20, 2020

Copy link to clipboard

Copied

I appreciate this great info. Will def. have to put some time aside and play with the "Sharepoint Migration Tool". 
In the meantime, had a breakthrough on my end. Posting it here in case you haven't tried it and in case it might help others. After following all of those steps, I'm able to upload ASPX files into Site Pages and any other Library. And they open right away in browser no matter whether I click on them or go to the direct path. 

  1. Enable "Custom Scripting" (can be done for the individual site via PowerShell or by an SP Online Admin for the entire collection of sites (via the GUI)
  2. As a site owner, go to Settings -> Site Permissions -> Advanced Permissions and check yours. There's a chance that at the bottom it will tell you that your "Add and Customize Pages" permission is denied. If it states that, this is what you need to fix in order to eliminate the ASPX file challenges. Even you have Full Access as an owner and that permission is supposedly included there, there's probably a "global deny" on it and it can't be overwritten via the GUI. Even as an admin I don't have it (we tried on two SP Online Environments, one of which brand new out of the box setup). 
  3. Have your SP admin run a powershell script (which can be done for the individual site, unless they want to do it somehow for all sites:
    et-SPOsite <SiteURL> -DenyAddAndCustomizePages 0
  4. Just to be on the safe side, add you SP site to your browser's trusted sites

 

From here on, you should be able to:

  • Use File Explorer to drop your RH Output folder (with all the ASPX files in it) into any library (even Site Pages). And of course, easily open those aspx files from any browser. 
  • If you use Chrome or Edge, you can also go to Upload -> Folders and upload your entire Output folder in seconds (10 time faster than using File Explorer). The only library that doesn't have the upload feature of course is Site Pages. But using it becomes pointless if all the other libraries let you do anything that you desire with ASPX files.

 

Last but not least, you'll also have to make sure that those with lower access (your Members) can also view the ASPX website properly. You'll have to play with the permissions a little bit and see exactly which one(s) give them that access. I'm yet to confirm that on my end. Hopefully they can do this by default. 

 

Sorry if this is info that you already knew. Hopefully it helps. Cheers! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 20, 2020 Sep 20, 2020

Copy link to clipboard

Copied

I need to make a quick clarification/correction to my previous post (since I wasn't able to edit it). 

The key to success (at least for us) had to do with:

1. Having the SP admin enable Custom Scripting globally via Admin Center -> Sharepoint -> Settings -> Classic Settings Page. Then check these two:

  • "Allow Users to run custom script on personal site"
  • "Allow users to run custom script on self-service created sites"

2. Then despite of making the above changes globally, have the SP admin also run this powershell script. Without it, the "Add and Customize Pages"  permission will remain disabled for everyone on the back-end. Even for site owners and admins. 
et-SPOsite <SiteURL> -DenyAddAndCustomizePages 0

 

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

Hello,

 

I recently came across this string in my serach for assistance to publish from Robohelp 2020 to Sharepoint online. I've followed the very helpful instructions and uploaded the output file to the sharepoint page. I can successfully launch the index.aspx file, but when I clieck on one of the tiles to go into our knowledge base, I receive a file not found error.   I can't seem to get past our landing page.  What am I doing wrong, or is there a setting that I need to change to be able to see all of the documents past the landing page?  Thank you for any assistance that can be provided.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

Hello, 

 

This may be difficult to troubleshoot on here but lets give it a try. Worst case, it will help us gather some additional info that might help some of the other Robohelp gurus on here.  A few quick questions for you:

 

1) Could you please share the path/URL of the landing page as well as the path that you're taken to when clicking on any of the tiles? (and you're welcome to hide the SP site name and everythng to the left of it)

 

2) If you right click on any of the tiles, you should be able to look at the properties, and there should be a path and the file name at the end. Try to find the file in question in SP to see if it's even there. If it's not, then we may need to focus more on the batch upload/publishing process. 

 

3) Can you tell us how you published the content to Sharepoint? Did you upload it by manually through File Explorer (which you can open through IE11 for example)?

 

Thank you 🙂 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

Sorry, two more follow-up questions: 

 

4) Do you know if the SP Online site that you're using for your content was created using a Classic or Modern template? Classic seems to work much better from what we've seen. 

 

5) When you check YOUR permissions for the site, can you confirm that "Add and Customize Pages" shows as "Allow" and not "Deny"?

 

Thank you 🙂 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

Thank you so much for the quick response.  Because I was unable to create the connection profile, I uploaded the output files to sharepoint from file explorer.   I did add the "add and customize pages" permissions as well.  I can get to the table of contents but still cannot open up the documents within the TOC.  The files are there, they just won't open. the message says "something wrong. File not found."

 

I am not certain about the classic vs. modern template and can check that next.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2021 Dec 30, 2021

Copy link to clipboard

Copied

LATEST

You're very welcome and thank you for sharing those details. 

 

I'll add one more silly question:

When you click on a tile, is the file that you expect to open aspx, html (unlikely), or maybe an attachment like Word or PDF?

 

One thing that you can also try is to create a fresh dummy project in Robohelp with just 1 or 2 topics. Then generate a batch using the same type of template and Output. And if you run into the exact same issue once you upload it into SP, at least you'll know the issue isn't with your main project itself. 

 

We spent countless hours back at the time and at the end had to simply try diferent things and go by process od eliminaoin. Fingers crossed you don't have to walk that entire path 🙂 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 17, 2020 Sep 17, 2020

Copy link to clipboard

Copied

Clear your browser cache and reload. Do this every time you publish. That worked for me when nothing else worked. (Thanks Microsoft)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 20, 2020 Sep 20, 2020

Copy link to clipboard

Copied

Many thanks for this tip. I can def. see caching issues all over the place.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

FYI for users struggling with publishing to SharePoint Online: Microsoft Tech Support and Adobe Tech Support working together actually solved my problem. Microsoft suggested that I create a folder in Documents and publish to it, not Pages. You need to have Admin rights to this folder as well as Admin rights to your computer. Plus clear your browser cache and reload every time you publish. Adobe upgraded me to RoboHelp 2020 which has lots of fixes. I put a link to the index.aspx file into the application that was using the Online help and was good to go. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp