Snippets appear only as hyperlinks

Explorer ,
May 11, 2020 May 11, 2020

Copy link to clipboard

Copied

I am using RoboHelp 2019. I don't understand why the body of a snippet will not appear when inserted in a topic.  Instead, it only appears as a hyperlink.  

On a different topic, the body of the snippets appears correctly when I drag and drop them. I don't know what the difference is and how to get the body of the snippet appear correctly on all topics. 

Views

346

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jun 02, 2020 Jun 02, 2020

I have to report that I don't think that updating was responsible for the snippets not appearing correctly.  Soon after I updated, I got the same behavior: snippets appearing as hyperlinks; not the body of associated text.

 

I think I see what the problem is....

I was dragging-and-dropping the snippet into a topic that did not have any space at the bottom (no return). In this state a blue arrow ("insert paragraph here") marker appears at the bottom of the topic. It seems the snippet appears as a hy

...

Likes

Translate

Translate
Adobe Community Professional ,
May 11, 2020 May 11, 2020

Copy link to clipboard

Copied

Are you all patched up? Check Help > Updates to check. Are you adding snippets in different ways on each topic?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 11, 2020 May 11, 2020

Copy link to clipboard

Copied

Thank you, Jeff.  I am using a trial version until the company licenses and installs our corporate copy. I did the update as you suggested and now the snippets appear correctly when dragged and dropped. Preupdate version: 14.0.12, Post update: 2019.0.12.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 11, 2020 May 11, 2020

Copy link to clipboard

Copied

Trial is the same as the "real" thing - it just expires. You still have to apply patches even if you just downloaded it fresh today.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 02, 2020 Jun 02, 2020

Copy link to clipboard

Copied

I have to report that I don't think that updating was responsible for the snippets not appearing correctly.  Soon after I updated, I got the same behavior: snippets appearing as hyperlinks; not the body of associated text.

 

I think I see what the problem is....

I was dragging-and-dropping the snippet into a topic that did not have any space at the bottom (no return). In this state a blue arrow ("insert paragraph here") marker appears at the bottom of the topic. It seems the snippet appears as a hyperlink in these cases.

TechWriter57_0-1591099052930.png

All I did was insert a return, then drag in the snippet into the topic. Then, the body of the snippet appeared.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

Hello

 

I would like to reopen this discussion as I would like to utilize the snippet as a hyperlink. When I drag a snipped from the contents>snippets folder it shows up in the topic as a hyperlink. This is great for what I am doing as I would like either a pop-up window or a new window to show the snippet if the reader needs more information. Is this possible? So far the hyperlink shows up but when selected nothing happens. How do I make it open the snippet in a new tab/window/popup window?

PhoenixAmour_0-1640104951531.png

 



Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 21, 2021 Dec 21, 2021

Copy link to clipboard

Copied

LATEST

The key things in this thread are:

  1. The user did not want it to appear as a hyperlink.
  2. Dragging a snippet should show the content of the snippet so anything else is wrong and should not be relied on.

 

Try creating a topic with just the snippet content showing. Then create a link to that topic and configure it as a popup. That is the correct way to achieve what you want. Don't forget to include the topic in the TOC and select Hide in Output if you are using the New UI version. Please include your version in new posts or your first post in a thread.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp