Type for some content reverts back after project is re-opened

New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Somehow some text in various topics got changed to a different Type.
example:  

*File name preceeded  by year

 

To fix it, I used Clear Formatting and the text returned to normal.  I then saved the project.

When I re-open the project the problem comes back.  Why is some text reverting back to a different (wrong) text style?

Views

126

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Where are you saving it to? Is there source control involved here?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Thanks for the reply.  No, I am saving it to my local PC.  Any other changes that I make remain when I re-open the file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

I'd have a look at the offending text in the code view - that might give you some indication of what's going on. Maybe a different style sheet is being applied to that content.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Here is the example.  The text "OY", "File" and "preceeded" all show as Type Span.  The rest of the page shows as Type td.  I remove the formatting from the bad text, save. and it all looks ok.  When I re-open the file it goes back to the unwanted formatting.

Neil24189636wy5b_0-1650911792684.png

 

Here is the HTML.

Neil24189636wy5b_1-1650911909560.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

That appears to be inline styling applied to most of the content - the offending line doesn't seem to have any style on it, so I would expect the CSS to control it. If you add words to that cell, are they saved?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Yes.  Any text I add in that sell is saves, but with the same (incorrect) Type.

One thing that I see is that the incorrect formatting seems to repeat among the same text in a topic.  For example, the designation "OY" displays in the wrong Type evrywhere it appears on the page.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

And what happens if you edit the text in code-view and add the styling to it? Is it saved? Where did this content come from? Was it created in some other program & imported into RH? I'm just wondering if some funky invisible characters have gotten into your cell.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Most entered directly into RH.  Some from Excel.  But if it was a copy issue, I would expect whole sections to be wrong.  As it is it is only certain words.  If a specific word had the wrong Type it is wrong everywhere on the page that it appears.  Most of this was hand typed in RH.

Ex: words in the same cell, one is right, one is wrong.  "OnBase Workflow"   Onbase is wrong Type, Workflow is correct.  Same format shows in HTML.
<tr>
<td style="margin-left: 8px;font-size: 10px">
<p style="margin-left: 4px">OnBase Workflow</p>

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

It definitely relates to the words.  One of the words that shows incorrectly is "OnBase".  No matter where I enter that word in my project, it formats wrong.  Even if the rest of the line I add it to is correct. How can a format/type be associated with only certain words?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

That is so weird. There is no html or css code on the "file name preceeded by" text that would make it display in different font sizes.

 

This is happening in the RH editor, yes? Not just in the output?

 

Can you create a new blank project and copy/paste that content into the project. Don't copy the stylesheet or anything, just the content. Does it happen in the test project too? If you open one of the sample projects, do you see that problem in any of the content provided?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Oh and which version of Robohelp are you using - include the full version number?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Has the machine been rebooted since this problem started?

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

I will answe everything here:

I am using v2019.0.11    I tried to upgrade, but the upgrade dialog box gets cut off and I cannot see the buttons in it.  Tried every combo of screen resolutions and settings to no avail.  Saw this before but have not yet figured out athe fix.

 

Yes: machine has been rebooted.  Prob was noticed last week.

 

Copied/pasted the contents from a topic with the issue to a new topic.  Page looked fine until I saved and re-opened.  Then prob appeared on the new topic page also.

 

The issue happens in the RH editor only. You may have highlighted the workaround.  I generated an output and in the published output the page looks fine.  I may have to just ignore this as the output looks fine.  I will make sure not to use this project as a basis for any new ones.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Try going to the updates page directly - https://download.adobe.com/pub/adobe/robohelp/2019.0.14/Setup.zip found on https://helpx.adobe.com/robohelp/kb/robohelp-downloads.html 
I forget - did you mention if this is a Classic project or one with the New UI?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

New one.

Thanks so much for your help...this is a weird one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

LATEST

You say "I am using v2019.0.11. I tried to upgrade, but the upgrade dialog box gets cut off and I cannot see the buttons in it".

 

So the problem is in 2019 Classic and you couldn't upgrade because of the above issue. I have seen that too. If you want to try upgrading again I have seen that problem and there is a workaround. When the dialog comes up you have to press the tab key, twice I think. You might then see the buttons but if not press enter anyway.

 

If you create a new project in Classic and import one offending topic, do you still see the problem?

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

New Users: Default forum names can be changed in your Account Settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp