Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Upgrading RH 2017 project to 2020 not working

New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Hi,

I downloaded yesterday the trial version of RH 2020 to see whether the upgrading of my 2017 project works correctly. The project is quite huge and contains around 18.000 files when published, I tried by opening RH 2020 and select Upgrade project. 

The process starts running but not even 20 seconds later I get the following error and the import fails, forcing me to shut down the application.

angelicas55431266_0-1616760661524.png

 

Could you please let me know how to tackle this issue and what could be the problem?

Thanks.

Angelica

Views

227

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 26, 2021 Mar 26, 2021
You need to edit the CSS. It will be in Assets > CSS. Double click it to edit it. Because of the issue it may only open in source view rather than the graphical editor.  ________________________________________________________ See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Well, first make sure that you've got the newest patched version of RH2020 loaded (should show 2020.4 now) - if it shows the initial RH2020.0 release, there was a bug that prevented the normal Help > Updates mechanism from working. In that case, go to https://www.adobe.com/support/robohelp/downloads.html and grab the last patch version. If Patch 4 isn't up there yet, loading 2020.3 will enable the Help > Updates to work to boost you to patch 4.
Then give your conversion a try again.
If it still fails, and you installed RH2020 with Admin rights - test out opening the sample project and see if all is well. If it's ok, then the issue has to be in your project. There are troubleshooting techniques for dealing with that too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

How many topics rather than how many files?

 

Were they in folders? Please tell me they weren't all in the root of the project. 

 

Post back when you have tried in Update 4.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Hi!

Thanks a lot for the quick answer! I updated RH and indeed the import now worked BUT with one issue:

Warning: Failed patching and copying CSS Dependencies from [path of .css file in the project]

Is there a way to try to reapply the CSS or force it somehow? Or any other way to solve this issue?

Thank you again!
Angelica

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Content of duplicated reply removed by moderater. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

You need to edit the CSS. It will be in Assets > CSS. Double click it to edit it. Because of the issue it may only open in source view rather than the graphical editor. 

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Hi Peter,

 

Thanks again for your answer. What do I need to edit in the CSS exactly? 

 

At the moment, the project seems to read the CSS but in the Styles pane none of the existing styles appear, it's empty.

Also, the topics' look seems overall to be fine, following the styles that were created in the previous version even if they do not appear in the side pane, and I only see an issue with the styles of some snippets that is not the correct one.

 

The following error keeps on appearing as well:

 

angelicas55431266_0-1616765691231.png

 

Any idea on how to fix this?
Thanks

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

There's a thread in the last couple of days that covers the most likely cause. Empty Styles or something like that.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

I found your solution in the other thread but I do not have any Media@mercycity.church only definiton in the CSS. 😕

What else should I do?

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

https://community.adobe.com/t5/robohelp/paragraph-styles-missing-and-application-error-after-upgrade...

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

I do not have any @Media only definiton in the CSS. 

What else should I do?

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

I managed to clean the .CSS and it seems like the styles now appear. The main issue stays with the snippets, that did not save their style when imported, and it seems like I have to reapply it one by one. Any solution for doing that in batch?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

You also try pasting in your CSS to this validator tool - https://jigsaw.w3.org/css-validator/

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

It found 189 issues but in 2017 and 2019 classic the projects and the styles are perfectly displayed 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Behaviour of snippets has changed. In Classic they took on the style of the topic but you could apply a CSS. Now it's the opposite. Check what CSS is applied and whether that is what you want.

 

I'm not seeing a quick way to change that.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

OK, I will try to do it manually.

What about the MiniTOCs, also the style of that seems not correct anymore hmm.

 

I tried anyhow to generate an output and it's been more than half an hour that says ''starting generation'' on the pop-up but no progress so far... is it normal?

 

Thank you again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

Everthing is different so the mini tocs may need some fixing too It might be worth looking at the RoboHelp Tour Introduction (grainge.org) on my site as there's lots of how to information there.

 

Half an hour does not sound right. Have you checked the preset? Maybe the configuration needs some tweaking.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Hi,

 

Thanks for your help! After fixing the CSS it seemed to work fine.

I am workin now on a script to automatically update the style of snippets and minitocs.

 

In the meantime, are there any templates of laytout skins available to download?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

Beside the ones already available in RH.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Hi there, any chance you have a script to convert CSS from RH 2017 to 2020 that you'd be willing to share? The upgrade mainly affects all of our list styles and there are a lot. Unfortunately not what we expected from the upgrade. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

I'm not sure what you mean by "templates of skins". The frameless skins are templates in the sense they can be heavily customised using the skin editor. Production of a skin from scratch is a highly complex task. It requires a designer to come up with the required style and developers to make that function.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

I see, I was just wondering whether there were other available skins already customised by users and uploaded in the forum somewhere, as it often happens for other software. 

 

Thanks anyhow!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

There is no repository of customised skins that I am aware of.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

I have no such script or I would willingly share it.

 

Now we know lists are the issue I suggest you take a look at the Lists and Autonumbering topic in the RoboHelp Tour. In particular the section Lists upgraded from Classic versions.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top. It helps keep posts in order.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

LATEST

Thanks Peter. I was hoping @angelicas55431266 might have one as they mention working on one in a previous comment. Fingers crossed.

 

Unfortunately due to time constraints our writer will likely have to install 2017 to complete this project. Inconventient, but the quickest way to solve our problem (short of a script). Will keep your article in mind in future though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation