• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

We currently have RoboHelp 2022 4.179, and are experiencing issues with the mini toc (In This Topic)

New Here ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

We currently have RoboHelp 2022 4.179, and are experiencing issues with the mini toc (In This Topic) where the link inside the mini toc does not go to the appropriate location. It takes you to an page within the output but not in the child project. I can revert to a previous version and have it work. So I'm thinking this is an update issue. Does anyone have any suggestions?

Views

151

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

The appropriate location being somewhere in the same topic? 

________________________________________________________
My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

Yes, the appropriate location should be within the same topic.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

When I revert to the previous update in my archive files the problem is not there. Also, we are generating in Framless.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 01, 2024 Jul 01, 2024

Copy link to clipboard

Copied

Have changes been made in the project since the archive version was generated.

 

I am guessing they have so we need to establish if the issue is the changes or the update. Create a copy of the archived version and generate that in Update 4. If it then breaks, it pretty much nails it being Update 4. 

 

It is important for both that and the current version that you regenerate all the projects starting with the parent. That's not normally a requirement but I think it is best when there is an issue.

 

Let me know how you get on.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2024 Jul 09, 2024

Copy link to clipboard

Copied

I can view the archived version but cannot move it to our test environment without updating the version. I am still experienceing the right side mini toc issues.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2024 Jul 09, 2024

Copy link to clipboard

Copied

You have lost me a bit. From what you have said, the archived version was known to be OK. The issue is whether or not the reason you now have a problem is either a change to the content or the update itself. We need to find out which it is.

 

  • If you create a copy of the source project from a backup that was created in Update 3 and worked, then upgrade to Update 4, if the problem occurs then patently it is the upgrade.
  • If that copy works after generating in Update 4, then the problem is something you have done in the project.

 

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2024 Jul 09, 2024

Copy link to clipboard

Copied

The archived version opens in the current RoboHelp version of 4.179. Some of the content is being updated, however, the content that is not being updated is also experiencing the mini toc issues of going to the incorrect page. We are using child projects with a merged output in framless. Any changes only happen inside the individual child project.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2024 Jul 09, 2024

Copy link to clipboard

Copied

So, the experiment's conclusions are - works in Patch 3, doesn't work in Patch 4 - correct?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2024 Jul 09, 2024

Copy link to clipboard

Copied

OK let me have a rethink.

 

Using the archived copy that is from Update 3 when you say it worked.

  1.  Open it in Update 3 create a copy of the preset in the errant project and generate it to a different folder. That way the output is then completely divorced from the merge. Child project outputs do not work properly when run independently of the merge and I want to rule out any issues caused by being a child project. I want you to test it as a standalone project.
    Does the problem still occur? If it does, then the problem is the child project rather than the Update. 
  2. If it does not, then run the new preset in Update 4. Logically it should be the same problem.

 

Let me know and I can then give it some more thought.

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2024 Jul 10, 2024

Copy link to clipboard

Copied

We ran another update from our original project (not the archive) and all seems to be working correctly in our test environment. I have absolutely no idea what changed. But it would appear tht something was not updating completely when we were running updates. I'll let you know if this happens again. Thanks for your help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2024 Jul 10, 2024

Copy link to clipboard

Copied

LATEST

I blame the elves having their playtime. 🙂

________________________________________________________

My site www.grainge.org includes many free Authoring and RoboHelp resources that may be of help.

 

Help others by clicking Correct Answer if the question is answered. Found the answer elsewhere? Share it here. "Upvote" is for useful posts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp