Highlighted

Adobe RoboHelp Version Control via Team Foundation Server

New Here ,
Jun 06, 2016

Copy link to clipboard

Copied

Hi Everyone,

For the last several months I've been working in RoboHelp to stand up a new project for a client. This client utilizes Team Foundation Server (TFS) to store and deploy code to the system. As such, RoboHelp was integrated with TFS via version control so that multiple individuals could access RH from different locations and update content, as necessary.

I have found that I am having several issues:

1. Multiple files do not appear to be shared or pulled into RH even though they exist on TFS. For instance, I created 2 different Responsive HTML 5 output files and although they exist on TFS after I checked them in, I recently upgraded RH and the files no longer appear in the Outputs pod. Additionally, no one else can get the outputs that I created to appear on their local versions of RH.  Thoughts?

-- Some additional files that do not appear to be updated properly via the TFS/RH connection include: WebAppHelp.hhc, any snippets, any output files, rhbuildtag.apj, rhlayout.apj.

2. After a user creates topics and checks them, the next user who accesses the RH project from a different computer finds that the newly created topics appear in their broken links folder.  Why is this and what steps should we take to eliminate this issue?

Views

455

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe RoboHelp Version Control via Team Foundation Server

New Here ,
Jun 06, 2016

Copy link to clipboard

Copied

Hi Everyone,

For the last several months I've been working in RoboHelp to stand up a new project for a client. This client utilizes Team Foundation Server (TFS) to store and deploy code to the system. As such, RoboHelp was integrated with TFS via version control so that multiple individuals could access RH from different locations and update content, as necessary.

I have found that I am having several issues:

1. Multiple files do not appear to be shared or pulled into RH even though they exist on TFS. For instance, I created 2 different Responsive HTML 5 output files and although they exist on TFS after I checked them in, I recently upgraded RH and the files no longer appear in the Outputs pod. Additionally, no one else can get the outputs that I created to appear on their local versions of RH.  Thoughts?

-- Some additional files that do not appear to be updated properly via the TFS/RH connection include: WebAppHelp.hhc, any snippets, any output files, rhbuildtag.apj, rhlayout.apj.

2. After a user creates topics and checks them, the next user who accesses the RH project from a different computer finds that the newly created topics appear in their broken links folder.  Why is this and what steps should we take to eliminate this issue?

Views

456

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Jun 06, 2016

Copy link to clipboard

Copied

Most of the time, the CPD file (cache) file is in the way. In the RoboHelp options, please select the option to always clear cache before opening a project. That will require RH to always rebuild the cache and have it pick up new files.

I suspect that this may also solver your first issue. The cache simply isn't up to date with the latest changes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 06, 2016

Copy link to clipboard

Copied

Hi William,


Thanks for your feedback. I checked the box to clear cache before opening the project and then re-opened the project. The following files still did not update on the Outputs(SSL) pod in RH for the project:

Internal.ssl

External.ssl

Printed Documentation_Adjudication.ssl

(There are many more ssl files that did not re-load into my local version of RH via the Outputs(SSL) pod but I only listed a few above.)

It looks like somehow my SSL files were overwritten in TFS so now we are trying to bring them back from history.

I'll apply the "clear cache" checkbox to my coworkers to see if it clears up the issue for them with broken links.


Thanks,

Tiffany

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Amebr LATEST
Adobe Community Professional ,
Jun 09, 2016

Copy link to clipboard

Copied

Also make sure the .cpd file is not in TFS as this causes all sorts of problems. (And remove the .ldb and .pss if they happen to be included, too).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...