Application Error when opening RH2019 or RH2020

Participant ,
Dec 23, 2020

Copy link to clipboard

Copied

When I open the rewrite (not the classic) version of  RH 2019 (2019.0.14)  or RH 2020 (2020.0.156), I now get an Application Error: The application has run into an error..." message, even before I open a project.  If I follow the recommended option of clicking "Help > Restart RoboHelp", the message redisplays when the application opens.  If I close the message and continue, I can open a project, view individual topics, view html, and see a conditional preview, but the error re-displays after most actions I take.  If I try to generate a frameless output, the system never finishes generating the output and the output folder remains empty.  I rebooted my system.  No change.  I checked for updates. None related to RoboHelp were available.

Details: Both versions of RH were working fine this morning.  When the RH 2019 rewrite first came out, I started customizing a frameless layout, hit some snags, and put the project on hold.  Yesterday, I resumed the process, experimenting with converting files from RH2019 Classic to RH 2020, and from RH2019 Classic to RG 2019 rewrite and then to RH2020.  I saw the message a few times yesterday, cleared it, restarted, and things seemed to go OK. Today I made the progress I was hoping to make, and I was able to generate and view the frameless output via RH2020.  I started documenting my process, beginning with an RH2019 classic copy of the project, and then started receiving the error all the time.  None of my frameless projects work now.  Skins are disappearing.  If I recreate them, I get the error.  If I try to proceed by re-adding one to the frameless layout, I get the error again.  I still get no output.  If I restart, the skins are gone, the frameless layout only shows the General and Content options; the Layout options (where you would select a skin) and all following options are gone (presumably because the system doesn't detect a skin to add).  Open to suggestions.  Note: After today, I will be on vacation until next year so it will be a while before I reply.  Thanks!

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

The first thing is that "I checked for updates. None related to RoboHelp were available" is incorrect. You have been caught by a bug in that release. It is explained in the forum Announcements.

 

You cannot update from the initial release (2020.0) using Help > Check for Updates. Go to https://www.adobe.com/support/robohelp/downloads.html and download the latest update. You only need to apply the latest as it includes the incremental changes. Once you have applied a later update, Help > Check for Updates will work in the future.

 

That is a complete installation. Normally you would apply it over the top of the existing installation but in your case I would uninstall your version first, then apply Update 3.

 

Does that fix the issue? If not try opening the About RoboHelp sample project that you will find on the Starter page.

 

Post back when you have tried that.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

TOPICS
Output presets

Views

68

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Application Error when opening RH2019 or RH2020

Participant ,
Dec 23, 2020

Copy link to clipboard

Copied

When I open the rewrite (not the classic) version of  RH 2019 (2019.0.14)  or RH 2020 (2020.0.156), I now get an Application Error: The application has run into an error..." message, even before I open a project.  If I follow the recommended option of clicking "Help > Restart RoboHelp", the message redisplays when the application opens.  If I close the message and continue, I can open a project, view individual topics, view html, and see a conditional preview, but the error re-displays after most actions I take.  If I try to generate a frameless output, the system never finishes generating the output and the output folder remains empty.  I rebooted my system.  No change.  I checked for updates. None related to RoboHelp were available.

Details: Both versions of RH were working fine this morning.  When the RH 2019 rewrite first came out, I started customizing a frameless layout, hit some snags, and put the project on hold.  Yesterday, I resumed the process, experimenting with converting files from RH2019 Classic to RH 2020, and from RH2019 Classic to RG 2019 rewrite and then to RH2020.  I saw the message a few times yesterday, cleared it, restarted, and things seemed to go OK. Today I made the progress I was hoping to make, and I was able to generate and view the frameless output via RH2020.  I started documenting my process, beginning with an RH2019 classic copy of the project, and then started receiving the error all the time.  None of my frameless projects work now.  Skins are disappearing.  If I recreate them, I get the error.  If I try to proceed by re-adding one to the frameless layout, I get the error again.  I still get no output.  If I restart, the skins are gone, the frameless layout only shows the General and Content options; the Layout options (where you would select a skin) and all following options are gone (presumably because the system doesn't detect a skin to add).  Open to suggestions.  Note: After today, I will be on vacation until next year so it will be a while before I reply.  Thanks!

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

The first thing is that "I checked for updates. None related to RoboHelp were available" is incorrect. You have been caught by a bug in that release. It is explained in the forum Announcements.

 

You cannot update from the initial release (2020.0) using Help > Check for Updates. Go to https://www.adobe.com/support/robohelp/downloads.html and download the latest update. You only need to apply the latest as it includes the incremental changes. Once you have applied a later update, Help > Check for Updates will work in the future.

 

That is a complete installation. Normally you would apply it over the top of the existing installation but in your case I would uninstall your version first, then apply Update 3.

 

Does that fix the issue? If not try opening the About RoboHelp sample project that you will find on the Starter page.

 

Post back when you have tried that.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

TOPICS
Output presets

Views

69

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 23, 2020 0
Adobe Community Professional ,
Dec 24, 2020

Copy link to clipboard

Copied

The first thing is that "I checked for updates. None related to RoboHelp were available" is incorrect. You have been caught by a bug in that release. It is explained in the forum Announcements.

 

You cannot update from the initial release (2020.0) using Help > Check for Updates. Go to https://www.adobe.com/support/robohelp/downloads.html and download the latest update. You only need to apply the latest as it includes the incremental changes. Once you have applied a later update, Help > Check for Updates will work in the future.

 

That is a complete installation. Normally you would apply it over the top of the existing installation but in your case I would uninstall your version first, then apply Update 3.

 

Does that fix the issue? If not try opening the About RoboHelp sample project that you will find on the Starter page.

 

Post back when you have tried that.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the blue Reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2020 0
Participant ,
Dec 29, 2020

Copy link to clipboard

Copied

Updating RoboHelp resolved the application error issue.  Thanks.  There are still some unresolved issues (e.g., the expand/collapse button stopped working).  Will look at those more next week.  Again, thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 29, 2020 0
Adobe Community Professional ,
Dec 24, 2020

Copy link to clipboard

Copied

Your other observation that things were working before & now are not, leads me to suspect that something in your environment changed. Did you install both versions with Admin rights?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2020 0
Participant ,
Dec 29, 2020

Copy link to clipboard

Copied

Thanks for the reply, Jeff.  Yes, both versions were installed with Admin rights.  Our company does not give us rights to install/upgrade software.  This may or may not be related.  I recall trying to use the frameless layout's skin's Download PDF button option.  Nothing happened.  Wondering if trying to use that option on the release I had installed caused the issue to occur. Wondering if there may still be an issue, at least in my projects, with the skin's buttons since the Expand/Collapse All button doesn't work.  I verified the button's "OnClick" text is still present and unchanged.  Again, will look at this more next week.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 29, 2020 0
Adobe Community Professional ,
Jan 04, 2021

Copy link to clipboard

Copied

With the Expand/Collapse All button, it only affects dropdown text within a topic. If you are expecting it to expand/collapse the table of contents, that's not what the button does. I only mention this because a couple of other people have had this expectation. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2021 0
Participant ,
Jan 04, 2021

Copy link to clipboard

Copied

Thanks, Amebr.  It appears to be a conversion issue.  When I convert a project from RH 2019 (rewrite, not classic) that includes a skin, the skin's Expand/Collapse button's OnClick field displays "rh.model.publish(rh.consts('EVT_EXPAND_COLLAPSE_ALL'), 'Expand');".  When this code is present in the skin, the Expand/Collapse button does not work for me when I generate the frameless layout output.  Today I created a new skin in an RH2020 project. The new skin's Expand/Collapse button's OnClick field displays only "EVT_EXPAND_COLLAPSE_ALL".  When this code is present in the skin, the Expand/Collapse button works for me when I generate the frameless layout output.  I am still seeing some other odd behaviors I can't account for yet that I suspect may also be conversion issues.  Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2021 0
Adobe Community Professional ,
Jan 04, 2021

Copy link to clipboard

Copied

If you can reproduce with another test upgrade from 2019 New UI, it would be worth reporting here: https://tracker.adobe.com/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2021 0
Adobe Community Professional ,
Jan 05, 2021

Copy link to clipboard

Copied

Did you do another conversion from RH2019 to RH2020 with the third patch applied? I forget if you mentioned that or not. If converting again doesn't fix that OnClick issue, I would report it as a bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 05, 2021 0