Highlighted

Auto-sizing Popups in Chrome Not Working

Explorer ,
May 15, 2019

Copy link to clipboard

Copied

We use auto-sizing popup link frequently in our online help. They work correctly using the WebHelp format, a format we are moving away from, but I've noticed that they don't open correctly when we generate the content using our Indigo-based HTML5 Responsive Layout, at least not in Chrome or Firefox. By the way, the application the help is written for is currently only supported in Chrome. Hence my trying to resolve this issue with that browser. I'm using RoboHelp 2019 Classic (Update 7).

When I click a link using the auto-sizing popup, it opens as shown below:

html5 layout - auto-sizing popup issue example.png

If I configure the link to open as a custom-sized popup that works, see below.

html5 layout - custom-sized popup issue example.png

Has anyone else experienced this? This seems like a bug to me.

Topics

HTML5 layout

Views

212

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Auto-sizing Popups in Chrome Not Working

Explorer ,
May 15, 2019

Copy link to clipboard

Copied

We use auto-sizing popup link frequently in our online help. They work correctly using the WebHelp format, a format we are moving away from, but I've noticed that they don't open correctly when we generate the content using our Indigo-based HTML5 Responsive Layout, at least not in Chrome or Firefox. By the way, the application the help is written for is currently only supported in Chrome. Hence my trying to resolve this issue with that browser. I'm using RoboHelp 2019 Classic (Update 7).

When I click a link using the auto-sizing popup, it opens as shown below:

html5 layout - auto-sizing popup issue example.png

If I configure the link to open as a custom-sized popup that works, see below.

html5 layout - custom-sized popup issue example.png

Has anyone else experienced this? This seems like a bug to me.

Topics

HTML5 layout

Views

213

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
May 15, 2019

Copy link to clipboard

Copied

Have a go in one of the sample projects to see if its a problem there. If it works, then it suggests there's something in your project causing the effect. If it's a problem in the sample, that might indicate an installation problem or a bug in Update 7. (I'd test myself, but I don't currently have Update 7.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 16, 2019

Copy link to clipboard

Copied

Also, I forgot to add that we are publishing the files to RoboServer 10 (Update 1).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 16, 2019

Copy link to clipboard

Copied

Just a suggestion to see if it's the influence of RH Server or not - see if it misbehaves when you look at the pages locally.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
May 21, 2019

Copy link to clipboard

Copied

It happens locally (i.e., on my hard drive) and on the server. And I've tested this using both absolute and relative links.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 22, 2019

Copy link to clipboard

Copied

Did you try one of the sample projects as Amber suggested? I just tried Employee Care 3 with the Indigo layout and the auto-sized popup worked correctly in both Chrome and Firefox.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...