Highlighted

Best WebControl for Embedded Window for Responsive HTML5?

Enthusiast ,
Feb 27, 2018

Copy link to clipboard

Copied

RoboHelp 2017 (13.0.2.334)

Windows 10, 64-bit (version 1709)

Our app uses C# with XAML. We want to display the Responsive HTML5 layout in an embedded window inside our application. This will eventually allow us to show our help side by side within our app, pin or collapse the help window to the side, etc.

We have created a container window in our app to do this. But we are running into some problems with the WebControl that MS provides.

Some problems we're experiencing:

- Problem 1) Some topics don't appear at all.

- Problem 2) Search doesn't work (already mentioned in this thread and might be a RH issue).

- Problem 3) In topics with drop-down contents, our twisty link that appears at the top of those topics don't expand drop downs. (But manually clicking on individual drop downs still works.)

Has anyone done anything similar with an embedded window in their app that displays their responsive HTML5 help content?

Is there a better WebControl we should use?

TOPICS
HTML

Views

369

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Best WebControl for Embedded Window for Responsive HTML5?

Enthusiast ,
Feb 27, 2018

Copy link to clipboard

Copied

RoboHelp 2017 (13.0.2.334)

Windows 10, 64-bit (version 1709)

Our app uses C# with XAML. We want to display the Responsive HTML5 layout in an embedded window inside our application. This will eventually allow us to show our help side by side within our app, pin or collapse the help window to the side, etc.

We have created a container window in our app to do this. But we are running into some problems with the WebControl that MS provides.

Some problems we're experiencing:

- Problem 1) Some topics don't appear at all.

- Problem 2) Search doesn't work (already mentioned in this thread and might be a RH issue).

- Problem 3) In topics with drop-down contents, our twisty link that appears at the top of those topics don't expand drop downs. (But manually clicking on individual drop downs still works.)

Has anyone done anything similar with an embedded window in their app that displays their responsive HTML5 help content?

Is there a better WebControl we should use?

TOPICS
HTML

Views

370

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 27, 2018 0
Enthusiast ,
Feb 27, 2018

Copy link to clipboard

Copied

This might be optimistic, but it seems that our initial testing shows that the updated .js files that Adobe provided on Peter Grainge's site seems to have fixed these issues for us. Apparently, those files fix more than just Search not working.

In case any one else needs to apply the fix, here's how:
1) Locate where you installed RH. Under that, locate this folder ...\Adobe\Adobe RoboHelp 2017\RoboHTML\ResponsiveHelpExt\widgets\common\scripts. Then backup loadparentdata.js and loadprojdata.js (just in case).
2) Visit Peter Grainge's site here: Using RoboHelp 2017

3) Download the files under item 13 in the table.

4) Extract them to ...Adobe\Adobe RoboHelp 2017\RoboHTML\ResponsiveHelpExt\widgets\common\scripts, overwriting what's there.

5) Regenerate your Responsive HTML5 output.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Adobe Community Professional ,
Feb 27, 2018

Copy link to clipboard

Copied

There are other files in the download. The text file covers those as well.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Enthusiast ,
Feb 27, 2018

Copy link to clipboard

Copied

Ah I see. It looks like I was using the files Willam provided from that bug report, and I mistakenly thought they were from your site, since I had visited your site the same day I downloaded his .zip.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Adobe Community Professional ,
Feb 27, 2018

Copy link to clipboard

Copied

Yes Willam fixed it in a different way. One of the two files he changed has not been changed by Adobe so when the Adobe fix is released, you could end up with a mix of files that may not play nicely together.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
Enthusiast ,
Sep 20, 2018

Copy link to clipboard

Copied

Hi Peter,

Above you mention "...when the adobe fix is realeased..."
Do you know when they released a fix to those files or when they will release one?

I think I'm still using the fixed script files from your site from when I posted last on this thread. I'm wondering, however, if those are the latest/best files to use, or if RH released something newer.

Anyway, on one of our projects, we're now getting multiple RH script errors when our help content loads inside of a new custom floating Help window that we use to display help for modal dialog boxes.The other embedded help window in the same app functions fine and doesn't give any script errors. The dev says he's using the same web control as in the other window, and I'm trying to figure out if something changed in those RH scripts, or if something else is going on.

See below.

I'm still using RH 2017 (13.0.2.334)

---

The help in our main embeded Help window works fine:

2018-09-20_11-44-44.jpg


But the help in our new custom window generates errors:

2018-09-20_9-00-32.jpg

2018-09-20_9-00-56.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0
Enthusiast ,
Sep 20, 2018

Copy link to clipboard

Copied

Nevermind on my last post.

I regenerated the help with our latest files and republished it up on our web server, our and now it's working.
Not sure what happened...
Sorry for the hassle.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2018 0