Browse sequence causes RH to hang when generating output (RH 2019, new UI, frameless)

Participant ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

Hi, Everyone.

 

I'm trying out browse sequences for the first time (RH 2019, new UI, frameless). When I apply my browse sequence to an output preset and generate output, the process hangs. It gets stuck with the generate dialog open, perpetually indicating the continuing activity. (See screenshot):

 

Browse sequence - hangs on.PNG

 

When I remove the browse sequence from the output preset, the output generates without any problem.

 

Any advice for me?

 

Thank you!

Views

75

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Participant , Mar 08, 2021 Mar 08, 2021
Well, I don't know how to explain it, but it's working, now. Jeff, I took your troubleshooting suggestion and tried the browse sequence with a different output (Responsive HTML5). And it worked. So tried re-building the browse sequence, just to see if maybe a fresh build would make any difference. And generating output with my regular output preset, the new browse sequence worked just fine. So then I tried the "faulty" browse sequence with my regular output preset. And IT WORKED! I have no idea ...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

What point version of RH2019 are you running? Are you all patched up? Check Help > Updates to check.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

Hi Jeff.

 

It's RH 2019.0.14 

 

Is that the latest update?

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

Nope, that's the last one for RH2019. Is it a number of sequences or just one? If it's a number of them, you could do some selective editing to see which one is giving the issue. If it's just one, can you try other output types to test to see if they choke on it too?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

Well, I don't know how to explain it, but it's working, now.

 

Jeff, I took your troubleshooting suggestion and tried the browse sequence with a different output (Responsive HTML5). And it worked.

 

So tried re-building the browse sequence, just to see if maybe a fresh build would make any difference. And generating output with my regular output preset, the new browse sequence worked just fine.

 

So then I tried the "faulty" browse sequence with my regular output preset. And IT WORKED! I have no idea why.

 

Any thoughts?

 

Thanks much, Jeff!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

Sorry, no clue - just the vagaries of the RH gods 🤣

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

PS:  I am having one new problem. I'm unable to get the top-level book from my TOC into the browse sequence.

 

Any advice on that?

 

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

PPS:  Here's a screenshot of what I mean.

 

Browse sequence - top-level book.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

Is there an actual topic within that "Start Here" TOC book? I always thought you needed to build a browse sequence with specific topics for it to work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

The short answer is no, there's not a topic in that book. HOWEVER, I've set the book up to operate as a topic using "Source" in the book's properties panel. If I double click the book in the TOC, it displays as a topic in the editing panel (screenshot):

 

Browse sequence - top-level book is a topic.PNG

 

I don't really remember why I did that. I guess I should just put an actual topic above the sub-book "About ETF"? 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2021 Mar 08, 2021

Copy link to clipboard

Copied

Browse sequences will only ever show the title of the topics in the sequence. So to add the "Start Here" book, you'd need to drag the "Start Here" topic into the sequence, and it would show in the sequence as "Start Here". You can't change the names as they aren't displayed anywhere, it's just a method of arranging topics so the Next and Previous buttons work in the desired order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

LATEST

Good to know, Amber.

 

I've put the topic into the sequence. And it works perfectly.

 

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation