Highlighted

Can we set Table of Contents as start page for mobiles?

Most Valuable Participant ,
Dec 23, 2015

Copy link to clipboard

Copied

Hi

I am using RH11.0.4 and publishing my course for mobile using PhoneGap Build. This is a mobile-only course. So I am not too bothered about how it behaves on desktop.

Though I have a Welcome page, I want my users to start with ToC. So, I set the Output Folder and Start Page settings to table_of_contents.htm instead of the default index.html. Since PhoneGapBuild won't publish the android app without index,html, I copied that file from older published version of the same course and published the app.

However, when I load it on my mobile, it still starts with the Welcome page and not ToC. Please suggest a workaround.

Sreekanth

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Can we set Table of Contents as start page for mobiles?

Most Valuable Participant ,
Dec 23, 2015

Copy link to clipboard

Copied

Hi

I am using RH11.0.4 and publishing my course for mobile using PhoneGap Build. This is a mobile-only course. So I am not too bothered about how it behaves on desktop.

Though I have a Welcome page, I want my users to start with ToC. So, I set the Output Folder and Start Page settings to table_of_contents.htm instead of the default index.html. Since PhoneGapBuild won't publish the android app without index,html, I copied that file from older published version of the same course and published the app.

However, when I load it on my mobile, it still starts with the Welcome page and not ToC. Please suggest a workaround.

Sreekanth

Views

1.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 23, 2015 0
Adobe Employee ,
Dec 24, 2015

Copy link to clipboard

Copied

Hi Sreekanth,

If you want table_of_contents.htm to be your landing page, then you can choose that to be your Default topic. When you generate Responsive HTML5 output, the start page(index.html) is only the layout.

Default topic is what user sees on their mobile. Keep the Output folder and Start Page settings to be the index.html (that way PhoneGap won't mind ) and just set the Default topic to be table_of_contents.htm

Edit Responsive HTML5 Settings > Goto Content Page > Select the Appropriate Default topic.

I have included a screenshot of how to change the default topic for your convenience:

ScreenShot4.png

Also I will suggest, you give a try to the Mobile App publishing capability from Robohelp 2015 itself. You won't have to manually go and build the App from PhoneGap site.

Create Mobile Apps using Adobe RoboHelp 2015 – TechComm Central by Adobe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2015 0
Most Valuable Participant ,
Dec 24, 2015

Copy link to clipboard

Copied

Hi Ritukumar

I have tried to set the table_of_contents.htm as Default Topic. But it won't show up when I click Select and browse for it.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2015 0
Adobe Employee ,
Dec 24, 2015

Copy link to clipboard

Copied

Is the table_of_contents.htm a topic in your project ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 24, 2015 0
Most Valuable Participant ,
Dec 27, 2015

Copy link to clipboard

Copied

No. It is the list of topics. In other words, it is the standard table of contents that appears on the right pane in the published output.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2015 0
LEGEND ,
Dec 29, 2015

Copy link to clipboard

Copied

Which layout are you currently using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 29, 2015 0
Most Valuable Participant ,
Dec 29, 2015

Copy link to clipboard

Copied

Willam, I am using the Theme1_Updated layout you have shared on your blog . I did not want the Search option as well. So tweaked that a bit.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 29, 2015 0
LEGEND ,
Dec 30, 2015

Copy link to clipboard

Copied

In the Screen Layout, select the Table_of_Contents.slp as the default page. (Expand the layout and right click the .slp). If you don't use CSH, that should open up the TOC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 30, 2015 0
Most Valuable Participant ,
Dec 30, 2015

Copy link to clipboard

Copied

Thanks Willam.

That got me the ToC as default page. However, when I first launch it, I get 2 header panels and 2 navigation panels at the bottom. Once I access some topic and go back to ToC, it gets right. Any idea why?

Here is a screenshot.

Responsive_HTML5_2015-12-30_16-11-54.jpg

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 30, 2015 0
Adobe Community Professional ,
Dec 30, 2015

Copy link to clipboard

Copied

I get that with Theme1 Standard, too. I think it's a "feature".

Willam might be able to suggest a fix, and the bug report form is here: https://bugbase.adobe.com/index.cfm

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 30, 2015 0
LEGEND ,
Jan 04, 2016

Copy link to clipboard

Copied

This definitely is a bug. I have only seen this behaviour before when the help was loaded in an iframe. Are you simply opening the browser or are you calling the help in a frame?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2016 0
Adobe Community Professional ,
Jan 04, 2016

Copy link to clipboard

Copied

I get it when using right-click > View With > Internet Explorer (9) or Chrome (47).

RH 11.0.4.291

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2016 0
Most Valuable Participant ,
Jan 04, 2016

Copy link to clipboard

Copied

When I view it in desktop mode, the ToC shows up in the Content pane first. Same is happening when we open it in mobile view.

Willam, I know you play a lot around css and js files. And, I think you have some solution ready for this (or similar issue). I am searching the forum and will check your website as well. But if you have it handy, please share.

Thanks

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2016 0
LEGEND ,
Jan 09, 2016

Copy link to clipboard

Copied

While I appreciate the sentiment, I don't have a script lying around. The best way to work around this issue is by opening the Table_of_Contents.htm file directly. If you do it that way, it works as you'd expect. In RoboHelp 2015 this issue is solved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2016 0
Most Valuable Participant ,
Jun 14, 2016

Copy link to clipboard

Copied

Hi William

I now have RH 2015. But I still cannot find Table_of_contents.html to set it as Default Topic. Am I interpreting your reply incorrectly?

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2016 0
LEGEND ,
Jun 22, 2016

Copy link to clipboard

Copied

Hi Shreekanth,

I'm not sure what I was referring to at that time. But you can set the TOC to be open/focussed oby default.

  1. In your layout folder, you'll find a file called usersettings.js. Open this with notepad or another text editor.
  2. Go to line 35, it will read: rh.model.publish(rh.consts('KEY_DEFAULT_TAB'), defaultPane);
  3. Add a new line and paste the following code: rh.model.publish(rh.consts('KEY_ACTIVE_TAB'), defaultPane);
  4. Save the file.
  5. Publish the layout.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2016 0
Most Valuable Participant ,
Jun 23, 2016

Copy link to clipboard

Copied

Hi Willam

I am using your Theme1_Updated (non-ToC) layout file. I did not find the usersettings.js in that.

I made the changes you suggested in the usersettings.js of the sample project, EmployeeCare3. It almost works. I mean, it flashes the ToC for a fraction of a second, but ends with the html page set as Default topic when I launch the index.html.

Btw, rh.model.publish(rh.consts('KEY_DEFAULT_TAB'), defaultPane); is on line number is 31 and not 35 as you mentioned.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2016 0
LEGEND ,
Jun 23, 2016

Copy link to clipboard

Copied

Hi Shreekant,

The instructions are for the Azure_Blue and Charcoal_Gray skins. No need to use the Theme1 layout. (Though you can import those and set the default page.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2016 0
Most Valuable Participant ,
Jun 23, 2016

Copy link to clipboard

Copied

I used the Theme1 layout as I wanted only the ToC (no search, glossary, and index.). But no luck so far.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2016 0
LEGEND ,
Jun 23, 2016

Copy link to clipboard

Copied

Try the new Azure_Blue! You have settings to disable the Index and Glossary 🙂 No coding required!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2016 0
Most Valuable Participant ,
Jun 23, 2016

Copy link to clipboard

Copied

But it has Search. I tried to remove that and now the topics are now showing up in ToC. I will continue to work on that part. 😞

In any case, the ToC (without its topics) is still flashing before returning to the Default Topic page.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2016 0
LEGEND ,
Jun 25, 2016

Copy link to clipboard

Copied

Search cannot be disabled through the editor. Do you want to get rid of that? Removing search is more of an operation as a lot of options depend on the option being there. If you are up to getting your hands dirty, you can try the SCSS files 😉

For desktop, you can choose to display search results in the topic contents. (Search (All) component) That moves them out of the sidebar.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2016 0
Most Valuable Participant ,
Jun 27, 2016

Copy link to clipboard

Copied

I managed to remove the search (or at least I think so for now). But I am still getting the error of ToC just flashing before I see the default topic.

Sreekanth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 27, 2016 0