Highlighted

Cannot open illegal or empty URLs

Participant ,
Jan 05, 2015

Copy link to clipboard

Copied

RH11 | WebHelp

I'm receiving the message "Cannot open illegal or empty URLs" when I open certain topics in one of my projects. I can click OK and the topics still open, but I'm unsure why this is happening.

Has anyone seen this before?

Thanks

Jonathan

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

It is this line in your table that is causing the problem.

<td style="background-repeat: repeat; background-attachment: scroll; border-bottom: Solid 1px #eee; background-image: url(#f8f8f8);"background="#f8f8f8" bgcolor="#F8F8F8">&#160;</td>

Set it to the same as other shaded rows and it works fine.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Topics

WebHelp

Views

383

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Cannot open illegal or empty URLs

Participant ,
Jan 05, 2015

Copy link to clipboard

Copied

RH11 | WebHelp

I'm receiving the message "Cannot open illegal or empty URLs" when I open certain topics in one of my projects. I can click OK and the topics still open, but I'm unsure why this is happening.

Has anyone seen this before?

Thanks

Jonathan

Adobe Community Professional
Correct answer by Peter Grainge | Adobe Community Professional

It is this line in your table that is causing the problem.

<td style="background-repeat: repeat; background-attachment: scroll; border-bottom: Solid 1px #eee; background-image: url(#f8f8f8);"background="#f8f8f8" bgcolor="#F8F8F8">&#160;</td>

Set it to the same as other shaded rows and it works fine.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

Topics

WebHelp

Views

384

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Jan 06, 2015

Copy link to clipboard

Copied

Any error in the developer console? Do you get the message as a popup or something else? Is there any custom script in those topics? Does it still occur after running Update DHTML effects in topics?

Kind regards,

Willam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jan 06, 2015

Copy link to clipboard

Copied

The message appears as a popop message when I open topics in RoboHelp. Some of these topics are brand new as well. They only have a title. There's no custom script or URLs in them either.

cannot-open-illegal-or-empty-urls.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jan 06, 2015

Copy link to clipboard

Copied

Hi there

Can you please share a screen capture of the properties of the hyperlink as well as what you are linking to?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jan 06, 2015

Copy link to clipboard

Copied

Here you go.

I'm using a variable in both the topic title and page title, but I've recreated the topic without this and it's just the same.

topic-properties.jpgtoc-page-properties.jpg

Cheers

Jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jan 06, 2015

Copy link to clipboard

Copied

Okay, I note that you are using a variable in the properties. While that shouldn't cause issues, does the problem disappear if you remove the variable reference?

Also, what have you done with the variable? Is the variable content possibly an empty link?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jan 06, 2015

Copy link to clipboard

Copied

Sorry, just re-read the bit about it happening to topics without variables.

If you created a totally new project or opened one of the sample projects, does the same thing happen? If it does, it might mean you need to reinstall RoboHelp, as it sounds like something related to your installation.

If it doesn't happen with the other project(s), it means this particular project has issues.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jan 07, 2015

Copy link to clipboard

Copied

Hi Rick

I've tried this in one of the sample projects and it doesn't happen, so I can only assume that it's an issue with this project. This project is a copy of an existing project, which I disconnected from RoboSource Control, so I'm wondering if that is causing it? I took a copy and disconnected it by deleting the .cpd and .pss files, and then removing the <miscproperties> entry (but leaving the closing </miscproperties> tag) in the .xpj file. I've done this many times and never had a problem though.

Cheers

Jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 07, 2015

Copy link to clipboard

Copied

Quite a few times I have seen people send me a project stating it has been removed from source control but when I open it, the project throws an error. Once that has been cleared, the project behaves.

If you have Rh on a non network machine, try that. If not, send it to me and I will open it here to see what happens.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jan 07, 2015

Copy link to clipboard

Copied

Okay Peter, I've sent it through to you.

Let me know how it behaves for you.

Thanks

Jonathan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jan 07, 2015

Copy link to clipboard

Copied

It is this line in your table that is causing the problem.

<td style="background-repeat: repeat; background-attachment: scroll; border-bottom: Solid 1px #eee; background-image: url(#f8f8f8);"background="#f8f8f8" bgcolor="#F8F8F8">&#160;</td>

Set it to the same as other shaded rows and it works fine.


See www.grainge.org for RoboHelp and Authoring tips

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jan 07, 2015

Copy link to clipboard

Copied

Well spotted and thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...