Controlling output when printing from Mini-TOC

New Here ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Using RH 2020, Update 4. The output is Frameless, using the Oceanic skin.

Is there a way to control the print functionality in the Mini-TOC? I would like to either have the printed file to contain the header and footer from the Master Page on each page, or have the Print icon open a designated PDF file. If I'm unable to do either, is there a way to disable the Print icon in the Mini-TOC? 

 

 

Views

160

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 07, 2021 May 07, 2021
With that prompt from @Stefan-Gentz I found the easier way in the skin editor. ________________________________________________________ See www.grainge.org for free Authoring and RoboHelp Information

Likes

Translate

Translate
Adobe Community Professional ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

The nearest I could find was deleting the icon in skin editor but it leaves a gap and the functionality is still there.

 

I can't see any way of editing how it works so your options as far as I can see are:-

 

See https://helpx.adobe.com/contact/enterprise-support.other.html#robohelp for your support contact options.

 

Please follow this link to request features. https://tracker.adobe.com. Post the link to your feature request in this thread and others can vote for it. The more people who do so, the higher it gets prioritised.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

If you want to hide the print button above the MiniTOC, you can do it by adding the following to the layoutdiff.css:

.RH-LAYOUT-RIGHTPANEL-print-button {
   display: none;
}

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Another tidbit for your site @Peter Grainge ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

With that prompt from @Stefan-Gentz I found the easier way in the skin editor.

 

image.png

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Thank you so much - Peter's suggestion worked. I'm glad that the solution was within the skin, and not a post-generation fix. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 09, 2021 May 09, 2021

Copy link to clipboard

Copied

LATEST

Is the problem that you have background shading on the footer and that doesn't print? If so I think that's a browser print setting that users have to change manually. This is partly an historical feature, from when colour printing was much more expensive, and also noisy background images were popular.  (hello MySpace 🙂   )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation