Highlighted

Copy/Past text

Community Beginner ,
Apr 29, 2019

Copy link to clipboard

Copied

Hi,

Copy/past part of a phrase (not even a paragraph) to another phrase from and to the same Topic;

  1. The part copied was automatically formatted (in bold) as the text already there.
  2. Selected the copied text to remove the bold format. Impossible.
  3. Had to click “Clear formatting” and reformat the entire phrase (Font, Size, Left Margin, Bold for part of the text)
  4. Why did it not accept the copied text as it was?

  Why did I have to Clear the formatting to reformat it???

Pierre

Views

200

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Copy/Past text

Community Beginner ,
Apr 29, 2019

Copy link to clipboard

Copied

Hi,

Copy/past part of a phrase (not even a paragraph) to another phrase from and to the same Topic;

  1. The part copied was automatically formatted (in bold) as the text already there.
  2. Selected the copied text to remove the bold format. Impossible.
  3. Had to click “Clear formatting” and reformat the entire phrase (Font, Size, Left Margin, Bold for part of the text)
  4. Why did it not accept the copied text as it was?

  Why did I have to Clear the formatting to reformat it???

Pierre

Views

201

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 29, 2019

Copy link to clipboard

Copied

Regarding 1. the text you copied was literally text only and took on the formatting of the element it was pasted inside. In this case the element was formatted as bold, so the text displayed as bold. For a discussion about what is updated when, see my response here: Margins

For the rest of it, I suspect a bug in 2019.0.5, but don't currently have a copy of 2019.0.6 to check if the fixes in that version have addressed the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 30, 2019

Copy link to clipboard

Copied

It's probably related to similar issues like in your other recent posts. It sounds very much like you had a lot of local formatting overrides in the paragraph where you pasted the text into. By resetting it to default with "Clear formatting" you got a "clean" paragraph now that you could work with fine. That's the best way to work.

BUT:

3. Had to click “Clear formatting” and reformat the entire phrase (Font, Size, Left Margin, Bold for part of the text)

It sounds like now you started to go into the same direction again that caused the original problem and will probably be a "solid base" for running into similar problems again in the future 😉

It sounds like you are manually formatting the paragraph instead of just applying a style to it. My recommendation is here to go into the CSS, create a proper style with all the formatting you want to have and then just apply this style to this paragraph and in the future to every paragraph that needs to have the same formatting. It's a small one-time effort but will be a HUGE advantage and big time-saver for your future work. Instead of formatting each and every paragraph locally in each topic in a certain way, it's more efficient to do it once in the CSS and then just apply this style to the paragraphs with one single click.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 30, 2019

Copy link to clipboard

Copied

Stefan Gentz [Adobe]​ I was getting some very odd behaviour trying to bold and unbold fresh, clean HTML content in 2019.0.5. Would you like me to log a ticket with the details or wait until I can try 2019.0.6 or .7?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 01, 2019

Copy link to clipboard

Copied

I selected some text in 2019.0.6 and applied bold using the icon and it was shaded. If you click again inside the span it shows shaded but if you select the same span, it does not. I would have expected the exact same span to show the icon shaded.

I also found that the method was to apply <span style="font-weight:bold;"> whereas if you use CTRL + B you get <strong> that doesn't show the icon shaded, which I think it should. Which is more correct I wouldn't like to say.

If your steps are the same, it seems to be OK in Update 6. Otherwise I'm happy to follow some instructions and see if I get the same.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 01, 2019

Copy link to clipboard

Copied

This is what I did:

1. Select 5 or 6 words and press Ctrl+B. The selected text is surrounded by strong.

2. Select one word in the middle of the bold section and press Ctrl+B. A span is added around the word, but the bolding is not removed. (it gets a <span style="font-weight:bold;">

3. Press Ctrl+B. The bolding is removed (<span style="font-weight: normal;">).

4. Repeat step 1 on some more text.

5. Select one word and press the B icon in the General panel. The bolding is not removed from the word.

So it seems that bolding isn't applied and removed consistently.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 02, 2019

Copy link to clipboard

Copied

Hi,

    Amebr: So it seems that bolding isn't applied and removed consistently.

Will this be reported.

I did not try Ctrl+B, always pressed B. Either one should add or remove Bold to the selection.

I was told that I was referring to the MS Word formatting. I think it's a very good reference.

Pierre

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 02, 2019

Copy link to clipboard

Copied

Amber will be offline right now. These issues have been reported.

Peter Grainge

www.grainge.org

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...