Highlighted

CSH calls using topic.htm instead of index.htm

New Here ,
Jan 09, 2018

Copy link to clipboard

Copied

We have context sensitive help links from our software to our help site. On William's site, it recommends to have the CSH URL from the software in the form www.helpsite.com/index.htm?rhcsh=1&rhmapno=10. However, I've found that www.helpsite.com/topic.htm?rhcsh=1&rhmapno=10 also works (replacing index.htm with topic.htm). Does anyone know of a reason NOT to use topic.htm in the URL? This method looks better to me as it reduces the number of redirects a user sees before the help topic is displayed, but maybe I'm missing something.

I'm using HTML5 layouts in RH 2017.

Topics

HTML5 layout

Views

167

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

CSH calls using topic.htm instead of index.htm

New Here ,
Jan 09, 2018

Copy link to clipboard

Copied

We have context sensitive help links from our software to our help site. On William's site, it recommends to have the CSH URL from the software in the form www.helpsite.com/index.htm?rhcsh=1&rhmapno=10. However, I've found that www.helpsite.com/topic.htm?rhcsh=1&rhmapno=10 also works (replacing index.htm with topic.htm). Does anyone know of a reason NOT to use topic.htm in the URL? This method looks better to me as it reduces the number of redirects a user sees before the help topic is displayed, but maybe I'm missing something.

I'm using HTML5 layouts in RH 2017.

Topics

HTML5 layout

Views

168

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 11, 2018

Copy link to clipboard

Copied

It's usually best to go with Willam's advice.

I found recently that if I clicked a topic in the TOC, the link in the address bar was somewhat different to the link if you followed it in File Explorer. Then if I used the link that was in the browser after I had applied an update to the help, it wasn't bring up the new stuff. Bizarre and illogical but that's the way it was.

I know your question is a different scenario but because of that blip, do test carefully if you do it any way other than as recommended.


See www.grainge.org for free RoboHelp and Authoring information.

@petergrainge

www.grainge.org for free RoboHelp & Authoring info. Use the blue Reply button at the top to help me help you.
The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...