Default start page in RoboHelp 2015

Explorer ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

I am using the Trial version of RoboHelp 2015. I successfully generated Responsive HTML5 output, except the default start page is somewhere in the middle of the Help rather than the first page of the TOC. Is there a way to edit the default start page either within the settings or the output?

Also, I am not seeing a previous/next page control within the output frame or header, is there a way to add them?

Thanx for any help provided.

-William

TOPICS
Classic, WebHelp

Views

2.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

LEGEND , Oct 07, 2015 Oct 07, 2015
What you will need to do is to right-click the topic that begins the third level and choose to create a book from the page.As for the Browse Sequences, while the old trick of using 0 for the level should work, the last couple of versions of RoboHelp now sport an option allowing one to create using the TOC "as is", so it shouldn't be needed any more .Cheers... Rick

Likes

Translate

Translate
LEGEND ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

Hi there

When you prepare to generate the output, you have an option to nominate a new Start page. Take a look at the screen shot below.

tmp1.png

For Previous and Next buttons, those are typically related to a Browse Sequence. You will need to first define a Browse Sequence. Click the Project tab and Browse Sequences to define one.

tmp2.png

Then in that dialog when you generate, click the Content section and ensure you enable Browse Sequences.

tmp3.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

Hi Rick,

That worked, although the browse sequences option is not available (nothing to select) in the content tab?

-William

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

Hi Rick,

So if I have a question on a new topic, do I start another discussion or continue in this thread?

My next topic is getting my heading 3s and 4s to acknowledge in the TOC. I wanted to give it a try using the right arrow function but it is not active:

toc-question.jpg

Please advise when you have a chance.

Thanx,

William

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

You can’t “demote” a topic if there’s no “book” to demote it under; you have to create a mid-level book for “sub-topics” to tuck in under in the TOC.

Re: browse sequences – you have to have defined them first before you can select them in the Content page of the SSL. If you want to have one that spans all topics in the TOC, you can use the “auto-creator” with a level of zero (that’s a trick setting that causes it to spin through all topics)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

What you will need to do is to right-click the topic that begins the third level and choose to create a book from the page.

tmp1.png

As for the Browse Sequences, while the old trick of using 0 for the level should work, the last couple of versions of RoboHelp now sport an option allowing one to create using the TOC "as is", so it shouldn't be needed any more .

tmp2.png

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

The output came out great Rick, thanx.

Ok last issue! (I think ), see image and call out below:

hyperlinks.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

Hmmm, for that issue you are likely going to have to do some HTML/CSS detective work. In RoboHelp, select across the text that is NOT appearing as you are expecting it to. Then click to exit Design view and reveal HTML view. The selected text should be selected in the HTML view.

My guess is that you have something amiss with the CSS associated with the text.

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

OMG, I regenerated and the TOC disappeared! Can I reinsert it?

toc.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

The first advice I would have is just to keep calm. Things are seldom as bad as they may appear at first glance.

Sometimes, simply re-generating will change things and poof! All is well again. Did you try that?

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

Ok, I am calm now but still confused because I regenerated still no TOC.

I see it in Tools toc report and in output view, what else can I check to see if the setting are correct?

toc.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 07, 2015 Oct 07, 2015

Copy link to clipboard

Copied

Try clicking the Output tab, then Output Setup. This should present the Outputs(SSL) pod. Then inside that pod, right-click the layout and choose Properties.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 08, 2015 Oct 08, 2015

Copy link to clipboard

Copied

I'm not sure what to look at in Properties. Can you have a look when you have a chance? Is there a specific part of the project folder I could send you?

Regards,

William

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 08, 2015 Oct 08, 2015

Copy link to clipboard

Copied

Actually I was hoping for a screen capture of the properties.

In RoboHelp you are able to create as many Table of Contents structures as you want. And if you have more than one, it's possible that you have managed to choose one that has no content. But in looking at this a bit further, in the image where you are showing the TOC has disappeared, it seems only the text has disappeared. I still see icons on the left side that would seem to imply the TOC *IS* actually there.

Curiosity question here. If you click the blank areas, does anything happen? Are you able to click and drag across them? (Thinking of a situation where perhaps white text is being presented on a white background and rendering the text as "invisible".)

Cheers... Rick

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 03, 2015 Nov 03, 2015

Copy link to clipboard

Copied

LATEST

Did you perhaps inadvertently change the color of the font to white?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation