Disappearing skin in RH 2020

New Here ,
Dec 29, 2020 Dec 29, 2020

Copy link to clipboard

Copied

Hi there,

 

I'm hoping someone can help with this as I've been wracking my brain and trying different things but cannot come up with a solution...

 

Yesterday I created a new instance of a Frameless Skin which I saved as 'Studio_Skin_CM_2.0'. I then spent much of the day editing that skin to bring it into line with our branding guidelines. 

 

I also created a new Output Preset for the folder which I called 'Output_Preset_CM_2.0' for the same project.

 

Today... I opened the RoboHelp 2020 and it is not showing the 'Studio_Skin_CM_2.0' which I created yesterday - just the default . After a moment of panic I clicked into the Output Presets tab and saw that 'Output_Preset_CM_2.0' *was*, thankfully, showing there.

 

When I click the 'view output' button from the Output Present tab it thanfully does generate content using the skin i spent much of the day editing yesterday.

 

The problem is that I cannot get into the skin to complete the required edits since it is not showing as an option in the skins tab. I can navigate to the filepath in robohelp project/ publish / skins but I cannot open or import the contents of this file.

 

If I click the import from the skin tab and navigate to th file then all of the files are greyed out. If I navigate to the file through finder (I am using a Mac) then the frameless.skn file is greyed out. If I right click and force it to associate with RoboHelp literally nothing happens.

 

So I am stumped. I can see the output is associating with the correct skin but this skin is not showing as available to edit through RH2020. The Skin file is the same location as the other two defaul skins that were showing with RH 2020 (Charcoal Grey and Azure Blue).

 

I have also tried creating a new test skin ('Studio_Test), clicking save and closing down the application. When I reopen the application this Test skin *is* showing in RH2020 as available to apply and edit. It is also showing in the *exact same location* as the one I edited yesterday ('Studio_Skin_CM_2.0') but that one still continues to be absent from the list of skins from within RH2020 itself.

 

Any ideas or pointers gratefully received as I spent a long time on these edite yesterday...

 

Thanks in advance.

Views

113

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 30, 2020 Dec 30, 2020
This is based on Windows but I'm assuming the same can be done on a Mac. First create a backup of the whole project so that if this goes belly up, you can get back to where you are now at least. OPTION 1 With the project closed use the equivalent of Windows File Explorer and delete the .rh folder and its contents. Then open the project again and see if the skin is back. OPTION 2 With the project closed open the two skins in a text editor. Copy the contents of the skin not showing. Dele...

Likes

Translate

Translate
Adobe Community Professional ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

This is based on Windows but I'm assuming the same can be done on a Mac.

 

First create a backup of the whole project so that if this goes belly up, you can get back to where you are now at least.

 

OPTION 1

 

With the project closed use the equivalent of Windows File Explorer and delete the .rh folder and its contents. Then open the project again and see if the skin is back.

 

OPTION 2

 

With the project closed open the two skins in a text editor. Copy the contents of the skin not showing. Delete the contents of the skin that is showing and paste in the contents from the rogue skin.

 

Does that get the show back on the road?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

LATEST

Good morning Peter,

 

Thanks very much for your reply.

 

I went with Option 2 and initially tried deleting and replacing just the frameless.skn files in text edit. That didn't work but I then just tried delelting entire contents of the skin folder that was showing with that one that wasn't... and now that show is back on the road.

 

Thanks again Peter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation