Double popup image with thumbnails - Studio skin

New Here ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

I'm working with RH 2020. In my project I have screens with thumbnails. When I generate output Frameless with Studio skin my images have double icon to open image in popup. The secound problem is when I open image in popup - there is double popup window, I must double click to closing icon to close popup. 
Have you ever meet with this issue? How can I fix it?

Views

146

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Nov 30, 2020 Nov 30, 2020
Normally you can use Help > Updates to check. But I think there was a bug in the first version which prevented the update working, so you can download manually here.  https://www.adobe.com/support/robohelp/downloads.html

Likes

Translate

Translate
Adobe Community Professional ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

First look in source view to see if anything looks wrong. 

 

If not try another skin to see what happens.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

 

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

Source view looks fine. 

I try another skin  frameless - TopNavigation and in this skin create one expand icon, one div with popup. 

Other skins in frameless view create double expand icon and double div with popup. 

I have no idea how to change that in Studio skin. I don't find difference in sources in skins. 

 

Moreover, on Robohelp Project Studio Compas i see the same problem with Studio skin. I think it's a bug. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

You refer to Robohelp Project Studio Compass. Do you mean the Compass Travel sample project or something else? If it is the Compass Travel project, which topic are you seeing this in.

 

Please confirm that with your project this double image problem occurs when you use the Studio skin but not the Top Navigation. Also please try the Orange skin with your project.

 

Whilst there could be a bug it seems unlikely as no one else has reported. Let's troubleshoot a bit more.

 

Come back to me with the above and I will take a look at Compass Travel as well.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

Yes, I meant the Compass Travel sample project 🙂 

For example topic New Chatbot for Customer Service has an one image with chatbot. I checked on this image property Use thumbnail. After that I generate an output frameless with skin Studio Compas Travel with skin Studio Compas travel (I think that skin looks very similar to standard Studio skin) and with checked parameter show thumbnail from images with style existing images. 

In output I see small images 100 px width with double expand icon and when I click on this icon I see two popup windows. 

The same problem I have with Orange skin on my project and Compas travel project too.

I attached two images with problem on orange skin. double expand icon.pngdouble popup.png

Thank you very much for your fast answer. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

There seems to be an understanding issue here. Your first image shows the thumbnail and when you click on that you are seeing the full size image.

 

You have said In output I see small images 100 px width with double expand icon and when I click on this icon I see two popup windows. 

 

Where is the second popup?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

The second popup is the same as first I and see it under first popup. 

When I want to close the popup window I must click double on close-icon. I think it's double popup. In Dev Tools I see double the same div. 

I attach gif shows double click on close-icon. Have you got the same problem? 

closepopup1.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

I'm not seeing that. 

 

This is what I see in the source view.

 

<body>
<h1>New Chatbot for Customer Service</h1>
<p>A new Chatbot customer service feature is coming soon! It adds artificial intelligence and machine learning to provide user assistance around the clock. </p>
<p><img data-thumbnail="50 74" src="../assets/images/image1.png" /></p>
</body>

 

Check there in Compass Travel and let me know what you see. Also check the source of your own project, that's all you should see for a thumbnail.

 

In the About RoboHelp sample project you can locate instructions for how to get a fresh copy of the sample projects. 

 

Let us know what you find.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Hello Peter, 

In source I see the same code what you send

Kataryna5FE8_0-1606776426703.png

I think source is good.

But my problem with double icon and double popups shows after generating output with Studio skin. The JS script topicpage.js may cause problem with creating double object on web site. 

 

I get fresh copy of sample project and I see the same problem 😞

I have RoboHelp 2020.0.156 is there any newest version? 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Normally you can use Help > Updates to check.

 

But I think there was a bug in the first version which prevented the update working, so you can download manually here. 

 

https://www.adobe.com/support/robohelp/downloads.html

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

Post back when you have applied the updates.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

Thank you Peter for your help! 🙂 

In the newest version problem disappeared and generated output looks fine. It's only one expand icon and one popup. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

LATEST

Glad it's all working.

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Please use the Blue reply button at the top to help me help you. The black Reply link nests replies and they sort out of order.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation